can't get rid of space occupying blank areas in table cells

There are areas of empty space in the cells of my table which ends up making the table too long. I think I tried all options in the format menu to get rid of the areas of empty space and have the text occupy it, to no avail.

thanks in advance for your time and help

I urge you not to try to waste your time making the Scrivener Editor (actually, from Apple I think) work well with complex tables. Simple tables probably work, but I avoid that also. It is impossible to bend Scrivener to your will for Tables. Tables are complicated, and too complicated for Apple’s editing tool.

Better, make your tables in some other tool. Paste PNG images of the pretty tables into your Scrivener document. Put the files for that tool in the Reference part of Scrivener. When you update.

Tools I use include:

Excel
PowerPoint
Pages
Numbers

I understand what you are saying and thank you.
Tables aside, for my own education and to better understand formatting, I would like to know what causes that space and how to remove it. No indents, not tab: what creates that space ?

Would be useful for helping you if you post a screen shot showing the “invisible” characters. Also confirm the style attached (if any) to this text, and if so how is that style defined?

As the other have said. Don’t waste your time on formatting complex tables in Scrivener’s editor. And adding to that, don’t bother about complex formatting at all while you write! You’re wasting your time. Scrivener’s editor is not a wysiwyg editor. You format the text afterwards, when you compile to some output format.

  • no style attached
  • invisible none in that area except for enter at the end of each paragraph.
    thank you

OK thank you

My guess is that there are settings in the ruler that affects what is shown in the table image. It looks like the line is set not to start at zero and with an indention of following lines, like if you have bullet lists.

I tested both and it’s neither.
I am surprised that nobody from Scrivener has replied.

If you cut and paste text from somewhere else, it will probably carry formatting into the cell. You could try cutting the text, pasting the text into TextEdit, converting it to plain text, and pasting it back into Scrivener.

Also, be aware that each individual cell will have its own ruler, with its own margins and tab stops. The ruler settings for the page, and the paragraphs around the page, do not necessarily apply to the table cells. And the ruler for one cell will not necessarily apply to the cell next to it.

This is primarily a user forum. If you want support from L&L you should mail their support mail.

I’m pretty sure lunk is correct. Try a third way. Put the cursor in the cell, with ruler on, look to see the paragraph setting. Each cell has its on individual ruler. Put cursor in each cell, then look at ruler.

thank you all for your suggestions.
I did test the ruler with the cursor in each cell, and it is not the ruler

The ruler does nothing. It just shows the formatting for the paragraph in which you have placed the cursor.

At this point … I’m going back to my original suggestion. Don’t use Scrivener for tables.

We do sleep occasionally. And sometimes take weekends off.

My guess would be that the paragraph is formatted with a hanging indent. If that’s not it, I’d need to look at the project directly. You can open a support ticket here:
literatureandlatte.com/contact-us

Katherine

Edit: What version of Mac OS do you have? There are some bad known bugs in the Big Sur beta’s text editor.

I apologize for the comment.
I wrote to you directly yesterday.
It is not related to hanging indents.

I ruled out the following:
– misplaced ruler (I also checked the ruler with the cursor inside the cell)
– strange formatting (no formatting characters)
– wrong alignment. (I checked with the cursor inside the cell
– list mode (list is none)

  • format → paragraph → all types of indents

thank you Katherine

Katherine kindly provided the explanation when I contacted Scrivener support
thank you Katherine
Reproduced here with her permission

I’ve been able to confirm the issue. Unfortunately, you seem to have encountered a bug in the Mac OS system that Scrivener uses: the same behavior occurs in TextEdit.
Probably the best workaround would be to remove the table, reformat the text, and make a new table. I’m sorry for the inconvenience.