Can't Get the Right Font in the Compile Doc

I can’t seem to get Compile right for documents that need to be in docx format.

When I write I indent paragraphs, have 1.0 line spacing and the font is Times New Roman 12 pt. The people for whom I am writing want no indents, 1.5 line spacing, Arial, 11 pt.

I’ve created a project format in “Compile For; Microsoft Word” that I hoped would transform this


into this

However, nothing I do seems to do two things I want:
1-get rid of the indent at the beginning of the paragraph
2-turn the main body text into Arial 11 pt .

I’ve set the margins and changed the font in every possible place that seems relevant. Wondering just what I am doing wrong here.

David

Hi :slight_smile:

You have to set the new formatting in your compile format :
To access those settings, double click the compile format in the list, left side of the compile panel.

image

(Those are screenshots from the Windows version of Scrivener ; they look different, but otherwise everything is the same.)

Section Layouts tab :


Click in the demo text and then do the adjustments.

→ It is imperative that you check the option (blue arrow) to override the editor’s formatting.

This needs to be done for all the section layouts of your compile format that are used in the project.
( → Top part of that same tab/pane.)


Now, if in the editor you used styles for your paragraphs, that will do nothing for those said paragraphs.

In this case you have to add the style(s) you used to the list in the styles tab, and adjust the formatting there, per style :

→ Do so for each style you used.
→ And make sure to check those two options at the bottom :
image

. . . . . . .

If you can’t there tweak your styles’ formatting to your need (some settings are grayed out), you will have to save and exit the compile format and compile panel, and, in the editor, from a selection of text to which the concerned style was previously applied, redefine the said style so that it saves all formatting :

image

(Not sure, but I think you might also have to remove those styles from the list in the style tab, then add them again so that the change is taken into account.) [ ← Yep, I just tested it.]

After which you will have full control on their compiled output.

. . . . . . . . . . .
That’s it ! – Hopefully I didn’t make it sound too complicated :wink:

Thank you! I really appreciate this detailed and step-by-step answer.

It still doesn’t work, for reasons I don’t understand. But I will try the “save all formatting” trick next and hope for better. It is truly puzzling, though, that even though everything in the Styles list says Arial (and gives an Arial preview), the font still comes out as Times New Roman in the Word doc. Even though the Styles screen looks like this

I am still getting a different font than Arial when I compile.

On to the next step, then.

Thanks again!

David

PS Font problem solved. In “Section Layouts” I clamped the font to Arial for everything. Still can’t get the indents out, but research continues…

David

Indents :

image


P.S. Technically, unless you actually didn’t use those styles, the section layout’s formatting shouldn’t have worked. And as only the last three of those styles are set to “save all formatting” (you can tell by the little “a” in the list’s icons) that would have made the others (those without that “a”) not fully reformattable by the styles panel’s settings.
image

One way or another, since it seems that none of those styles are either used in your project or related to your issue, I’d advise that you simply clear the styles panel list to avoid future problems.

1 Like

That was a good suggestion. By eliminating unused styles I was able to clear this up and get Compile to produce the style the editors want (no-indents included).

Thanks again!

David