Can't import doc files: Beta 1.7 and 1.8[BUG LOGGED]

I just started using Scrivener yesterday. So far, mostly good. But I cannot import .doc files into the binder no matter what I try. I get an empty document with the title of the doc file but no text and no icon indicating text file, pdf, or whatever. This happens every time I try to do so, using Finder or drag-and-dropping.

I upgraded to Beta 1.8 this morning and still having the same problem–can’t import doc files.

This is a newish Toshiba laptop running Windows 7 64-bit. Lots of memory, lots of disk space.

Someone else on Windows 7 64-bit can’t import docs or PDFs (per the Tech Support forum). I can import PDFs, jpgs, and txt files but not .doc files. I can import mpg, avi, and wmv videos but not flv or mp4.

I just installed Scrivener Beta 1.7 on an older Acer desktop running Vista 64-bit and was able to import .doc files into the binder in that installation. So this could be an OS-related bug.

I tryed to import PDF files on Windows Vista 64 bits and it didn´t work as well. All PDFs have 0 pages.

I didn´t try to import .doc files yet. (Edit: I just tested importing a .doc file and it worked ok)

Edit: my PDF reader is PDFXChangeViewer, not Adobe Acrobat.

Have you tried importing using the any document option?

If you the feature you are mentioning is the one available through “Ctrl + ALT + I” hotkeys, yes, I tried it.

The Any () option is on by default. If I change it to Text, then I can import a doc file. Thanks for the suggestion. I wonder why it works with Text but not with Any, though. And only with Win 7 64; no need to change the setting in Vista 64.

Even if I switch from “Any” to “PDF” the error still persists. I have tried version 1.9 too.

Here are the screenshots. I hope it helps:

  1. PDF selection:

  1. Importing Warning:

  2. Empty PDF file:

  3. System Info:

I am able to import DOC files.