Can't install the new beta

I tried installing the new Beta 0.2.9 over the older version on my computer (Windows XP). The installation setup box pops up, but there’s nothing in it, it’s just a blank window. When I tried it on my laptop, the information was there and I could install the new beta. I tried uninstalling Scrivener, but that didn’t work either. The older beta on this computer is expired, while the one on the laptop wasn’t. That’s the only difference I can see. Any ideas?

Have you tried downloading the installer again? It might just not have downloaded properly and thus won’t run. You could also try running the installer as admin if you’re not already and see if that makes a difference.

I’ve tried both. All the times I downloaded the program it was the same size, and I’ve tried running it on various accounts, but it still won’t work. Is there any way to wipe the program from my computer without using the Uninstall option or the Change/Remove Program option?

[Running XP SP3 on a Thinkpad A31 with 1gb RAM and cpu 2.0GHz ]
I tried to update from v.0.2.6 to 0.2.9 today, after uninstallnig 0.2.6. When I ran the installer it seemed to load ok, and produced the usual menu window inviting the user to run the installer. After a while, however, it stalled, leaving me with only a 3x3in blank window and no further activity. I have Microsoft Visual C++ 2008 installed and had no trouble with the previous beta. I downloaded three different instances of the beta but all of them failed.

Did SLynn get an answer to this question?

Thanks, DBC

If you haven’t already, before the reinstall you can first delete the Scrivener directory if that was created as part of the original install process and clear the registry file by opening Regedit from the Run menu and deleting HKEY_CURRENT_USER \ SOFTWARE \ SCRIVENER in that user account.

Hi MM,

Thank you for the suggestions, but both were already taken care of by the uninstall process. There are a whole bunch of other registry entries involving Scrivener, but I haven’t touched them.

I tried reinstalling v0.2.6, but got the same blank screen (it probably would not have installed in any case as its evaluation period was up). I downloaded the current beta on another Thinkpad and it installed without any problem. I then took a look in Documents and Settings and found a Scrivener folder in <name>\Application Data. It was empty, but I deleted it anyway. I also found C:\Documents and Settings<name>.scriv\settings\scriptformat.xml. So far I’ve just left it alone.

I’m not quite sure where to go from here. I tried go back to the restore-point before I uninstalled v0.2.6, but XP announced itself unable to complete the restoration.

DBC

Hm. It seems like there’s just something with the machine that’s preventing the installation–maybe something simple like a program you have running in the background from system start up. Try turning anything like that off (or creating a new account, but make sure in the new account that there aren’t any carryovers for “run at start up” programs, since some set in an admin account can run on all accounts) and then running the installer again. Even the 026 installer should have run, it just would’ve brought up a message when you tried to launch the program that it was out of date. But there’s nothing Lee’s been able to find as an issue with the installer itself, though he’s forwarded the issue to BitRock (who does the installer) so they may have some insight. So it seems like there must be something particular about your system set up on that machine that’s fouling the installer–unfortunately I haven’t had any bright ideas about what that might be. :confused: If you have any luck installing after turning off your other programs/services, let me know.

All righty, heard back from BitRock people; sounds like it’s usually from some incorrectly configured directories. If you could run the following command, run the installer, and then upload the .txt file created, I’ll shuttle that off to them and we’ll see what’s up.

From the start menu, run “cmd.exe”–you’ll need to run as administrator, so if you aren’t already in an admin account, make sure you right-click this and choose Run As and log in as an administrator.

At the command prompt, enter

set INITDEBUG=1 Scrivener-029-installer.exe > debug.txt

Then (leaving that open) run the beta 029 installer again. It’ll do whatever it does and will hopefully spit out some errors to a file called “debug.txt” that will be created in the directory listed in the command prompt, C:\Users[YourUserName]. Navigate to that folder in Windows Explorer and then either open the debug.txt file and paste the contents here or compress it to a zip file and upload it as an attachment to your post (you can delete the .zip afterward, but I believe straight .txt files won’t be accepted as attachments by the forum). After you’ve run the installer you can close the command prompt; the settings only last for that instance.

Thanks very much to you both. I’ll run through these ideas in the morning and report back.

DBC

MM:

  1. I disabled as many running programs as I could (ZoneAlarm, AV prog, and a number of other services) and ran the installer again; but no luck.

  2. I ran cmd.exe and pasted in the command you gave, then ran the installer. A debug.txt file was created, but it was empty.

I may have misunderstood your instructions so please let me know if so.

Thanks for your help.

DBC

Sorry, didn’t mean to leave you hanging. Sounds like you did it all right, so we’re waiting to hear back from BitRock.

Thanks, MM. No problem. These things take a while to sort out.

I tried the new beta 035 yestrday and today. I am afraid I am having exactly the same problem as with 029 - that is, the installation process froze, showing only a small blank square (as in the previous messages).

This what I have done so far (I’ve missed out the namy repetitions…):

  1. Generated a debug.txt file during the installation process. Again the file was empty.
  2. Unplugged all extra hardware (printer, floppy drive, second monitor), disconected from LAN and internet, disabled inessential dtartups, and booted into safe mode. This reduced my running services to 13 (including either Task Manager or Process Explorer for monitoring purposes).
  3. Ran beta 035, which froze again.
  4. Ran the beta while generating a debug.txt file. This time not even an empty file was produced.
  5. Ran beta 035 again while Process Explorer was running (but without trying to generate a debug.txt file), and saved details of invoked processes (dlls and handles) up until the installation process froze.

That’s as far as I have got. If the Process Explorer files might be helpful, let me know where to send them and I will do that. They are just text files, so the layout leaves something to be desired, but they show that the installation process had started up for a while.

DBC

I’m so sorry you’re still having trouble, and that I don’t have a positive word back for you yet to move you forward here. I will take whatever text files you’ve got–go ahead and send them to support AT literatureandlatte DOT com, and I’ll see if Lee’s able to get anything out of them.

MM,

Thank you very much. I’ll send them, together with a few more ideas ASAP.

DBC

Just to double-check, you’re running the installer straight from your Downloads folder or the desktop, and not through some other software, e.g. launching it from the browser’s “Downloads” panel? I assume you must be at this point, since you’ve tried so many times, but I’ve seen a problem reported due to indirect launch so I just wanted to double-check.

MM -

I ran v 035 from C:\install, using the Run comand for the tests .

Usually I run installations from another folder, C:\My Downloads\ starting them via my file manager, Total Commander. In fact this was how I installed v.026. But I wanted to rule out as many problems as I could so I isolated v.035 as much as possible after the inital installation failures.

Just in case, I tried just now to install from c:\Documents and Settings<my name>\My Documents\Downloads\Scrivener-035-installer.exe. (I have Administrator’s permissions.)

I imagine that is where most people install from, but it didn’t work. Thanks for asking though. These are just the sort of things that could make the difference.

DBC

You said you’re running as administrator every time you try the install with that debug command set, yes? Just want to double-check, as it won’t work if you’re running as a standard user, but I’m pretty sure that’s not the issue here…Thanks for bearing with us.

MM,

When I go to Control Panel >User Accounts I am clearly shown by name as Computer Administrator; so my named user account has Administrator privileges as far as I know.

But I note that today when I double-checked if I had administrative privileges another way, using run>cmd.exe.>net user I got the following:

"User accounts for//

Administrator ASPNET
Guest HelpAssistant SUPPORT_388945a0

The command completed with one or more errors"

Apparently ASP.NET is an account created by the.NET Framework for its own purposes. I uninstalled all my .NET Framework files about a month or so ago. (The fact that my Scrivener installation problems happened after this is suspicious though).Perhaps the continued presence on my computer of traces of this account may be producing some kind of arcane problem, even though I used the dotnetfx_cleanup_tool to tidy up afterwards.

I’ll look into it further tomorrow.

Thanks very much,

DBC

Crazy thought, here, but .NET was one of the packages I had to install to get it working for me. (WINE, but it’s the windows version…different API, same program.) Could it have some system check in the later installers that’s making your installation hang without an error? For the very first beta, it would install, but you couldn’t copy/paste. (So strange things happen when .NET isn’t installed with Scrivener.)