Can't mark and move text (Editor and Full Screen) since upgrade to MacOS BigSur

I work for years with Scirvener, it’s my main writing tool. Since upgrading to the latest Mac OS version (BigSur) I am no more able to mark and move text in the same document. This affects the normal editor as well as the full screen view. Do I ovelook something in the Scivener prefs or the OS prefs?
Scrivener 3.2.2
MacOS 11.6
Thany you for your help.

That doesn’t sound standard. To clarify, you can’t copy/paste or otherwise affect your text? But you are still able to add text?

Maybe start by resetting your preferences:

If it’s specific to a project (you can test with the interactive tutorial if you aren’t sure), you could also try resetting project displays:

If those don’t work, a fresh install may be in order.

Thank you.

Strange enough, in the meantime everything is back to normal. After several hours this morning, when the familiar marking and dragging did not work (marking worked, but I could not move the marked text to another place in the text) , all is ok again. I did not even a restart of the system or the program. Weird.

Today again I hat the situation, that the marking and dragging of text in the editor all of a sudden stopped working. Quitting and restarting Scrivener brought the function back. I wonder if this is a bug in MacOS BigSur or Scrivener.

It could be a bug. If you’re able to pinpoint any patterns, it would be good to send an email to Scrivener support to document. If you find that it only happens when you launch via the Dock or after making a change in a certain menu…things like that. Bugs can pop up periodically, but it’s hard for us to replicate and pinpoint them if you aren’t able to give us a pattern we can repeat to see it for ourselves.

If you haven’t tried resetting the preferences and project display, I would do that if it’s popping up on you now and then. Those are good first steps when Scrivener starts acting a little wonky.