Can't open .scriv file after downloading from Dropbox

Hi. I’ve just downloaded a backup from Dropbox and received my [filename].scriv.zip file. However, when trying to open it. I get nothing but errors.

If I try to double-click it I get:
The document “[filename].scriv.zip” could not be opened. Scrivener cannot open files in the “ZIP archive” format.

If I rename it to [filename].scriv I get:
The document “[filename].scriv” could not be opened.

However, here I get instructions to:
‘Try ctrl-clicking on the project in the Finder and selecting “Show Package Contents”, then look for a file entitled ‘binder.scrivproj’. Ensure it has not been renamed by a backup routine. If it does not exist, try restoring from a backup.’

But when I try this, Show Package Content doesn’t appear (macOS Monterey). I’ve done this before and got the file open (years ago) but it’s not working today.

Does anyone know how I’m supposed to get my scrivener file open? Does anyone have Monterey and can test out a dropbox backup, and confirm opening it works? I’m feeling a bit stuck here.

Thanks - Mark

Scrivener doesn’t open zip files. Period.

Decompress the zip file, and the result will be a copy of the project as it was when the backup was made.

On the Mac, generally, decompressing it takes nothing but double clicking on the zip file in Finder.

Show package contents is the wrong way to go. That’s for packages, not zip files.

1 Like

Solved.

Here’s what’s happening should anyone else experience the same:

Monterey is trying to assign the Dropbox .scriv.zip file to Scrivener instead of opening it with its default archiving app. Instead download the free app called The Unarchiver from the App Store. Right click the .scriv.zip file and extract it with The Unarchiver app. It should now extract correctly and reveal the .scriv file in the folder.

1 Like

not needed to get third party software. Finder will zip and unzip zip files.

Apple also provides a command line programs (zip and unzip as I recall without looking to confirm as away from Mac at the moment) to run in terminal is you want.

I wonder if finder was confused by the extension “scriv.zip.” I wonder double-clicking in finder would’ve worked if you’d changed that just to “.zip” Then, after it unzipped, one would have to add that “.scriv” extension back onto the resulting folder. Just a guess/thought.

1 Like

I tried this (as stated in my original post). Monterey’s Finder couldn’t open it.

Thanks. But I’ve solved it now :+1:

Good idea. I didn’t think of that :+1:

Problem solved now tho. Thanks :pray:

1 Like

if you rename as suggested by @jpkell does Finder work for your set up?

it is not usual to have two file extensions but. it impossible. Apple simply did not think of that, probably

I want to know (a) how it got that extension and (b) is it even possible to put . in the middle of an extension?

It’s not at all unusual for a file to have multiple extensions, though it is more often seen in cases like this, where one format is containing another. Technically, the only extension that matters should be the last one. Any tool or operating system that bungles that one has a bug in it.

And Apple should be aware of that, seeing as how that is how it assigns file names when compressing stuff through Finder. Try it. Right-click on “something.txt” and compress it: “something.txt.zip” (in every version of the OS from macOS 11 and older, anyway).

And that is how you get a “project.scriv.zip” so easily.

1 Like

Yes, and double-clicking on the result decompresses the zip file. I see no way to make macOS try to open project.scriv.zip as a Scrivener file.

1 Like

What would have worked with Finder:

  1. Control-click on zip file, choose Open With… and from the pop-up menu pick MacOS’s built-in utility (Archive Utility on my Mac).

  2. OP might want to tell Finder Apple’s built-in utility should be the default application to open zips. Select a .zip file, choose Get Info > Open With… and set it to apply to all files with same (.zip) extension.

That should fix the problem, but it’s still a mystery why it happened at all.

2 Likes

I confirm on MacOS 12.2.1 and 10.13.6 that regardless of how many “pseudo” file extensions there are, if the last one is “.zip”, Finder will un-zip as expected.

Agree … mystery why this was a problem at all, and certainly no need to install other third-party software to handle Scrivener backups.

2 Likes

I never came across this type of issue in 6 years at Apple and don’t recall it or similar ever hitting a support article, internal or customer-facing. The only way I can get that to happen is if the default app for .zip is set to Scrivener or an Open With.

1 Like

I agree, it’s weird. And I’m on a nice new fully updated M1 iMac and this is what’s happening: https://youtu.be/k8WNFr5TaGQ

My issue is now solved by uncompressing with The Unarchiver app - not the native Finder utility.

Renaming the extension from .zip to .scriv definitely would not allow Scrivener to open it as it is still a zipped file.

Humour me and right-click on the .zip file and select open with. What is the default app listed for the .zip file?

1 Like

It’s the Archive Utility app

If you change it to Finder, does it work as we expect?

Sadly not. Double clicking (or anything) doesn’t open in finder either.