Can't open Scrivener project on MacOS - emergency!

I have been a long-time Scrivener user, which I use for long-form article and book writing.

I cannot get one of my important projects to open. The project is 1.6 GB in size. I have the latest version of Scrivener on my Mac (3.2.3). I can open other files that are smaller (70 MB for example). I don’t know if the file is too large or if it got corrupted.

I use Microsoft OneDrive as backup. I have the folder that’s causing problems set to always keep a copy on my computer. But just in case, I downloaded the most recent version of my Scrivener project from OneDrive, renamed it and tried to open it. It still won’t open.

I have 11 months of data in this project for a book I’m currently working on, so I really can’t afford to lose it.

Can you help me figure out what to do, please?


What exactly is happening when you try to open it? Does Scrivener crash? Do you get the Spinning Beach Ball of Death? Does it show up blank?

Do you have a TimeMachine backup you can restore from? This the best, especially if you are going to restore standard Scrivener zip backups that are stored on your local drive.

Is the backup you put on OneDrive a copy of the scrivx file (which is actually a macOS Package consisting of hundreds or more files and folders), or the standard Scrivener Zip backups (which is one zip file)? The latter more reliable backup? If the latter, did you “unzip” before attempting to open?

Where is the “source” file kept? On a OneDrive or other sync folder?

Exactly! I get the spinning ball and then the application won’t open. Other projects open fine. So there is something corrupted in that project.

I have been able to download backups stored on my Mac. The most recent one gives me the same spinning beach ball. A previous one from two weeks ago does open but that, of course, doesn’t include much of the content I’ve been working on, so I don’t want to lose it!

I imagine that one of the settings is broken and needs to be deleted or fixed. Like binder.autosave or user.lock or ui.plist.

Any thoughts?

Hi RMS, No I don’t use TimeMachine. Everything is backed up to Microsoft OneDrive.I know that’s a problem sometimes b/c OneDrive moves some files to the cloud and off the computer, but I went and downloaded the most recent copy and unzipped it on my Mac, so it shouldn’t be incomplete. As I noted in my other comment, it seems that there’s some corrupt setting in that project.

The file on OneDrive is a copy of the main project, it’s not one of the Zip backups that Scrivner makes. As I noted, I found the most recent backup, unzipped it but it still crashed Scrivener.

I downloaded a copy of the latest version of Scrivener (which is what I’m using) and I could try to install that, although I’m not sure that’s the problem since other projects open fine.

Thoughts & thanks!

Two ideas:

  1. Wait. Maybe something is taking really long for whatever reason.
  2. Try this: Resetting a Project's Display Settings / macOS: Troubleshooting / Knowledge Base - Literature and Latte Support

Worse case scenario : you should be able to retrieve the content added since the last functional backup from the project folder of the dysfunctional version.
Not a simple task, but doable.

Dirkhaun’s suggestions are good.

A 1.6 GB project might take unusually long to open for any number of non-worrisome reasons.

Vincent: I can see all the content in the “Data” folder of “Files,” but my Mac doesn’t seem to be able to search inside those files, so going through them will mean looking one by one through hundreds if not thousands of files! I hope I can find another way to solve that!

Kewms: I don’t think that it’s just a huge file taking a long time to open. I’ve left it on its own to open for over an hour and I still just get the spinning beachball of death…

That would be for a very last (desperate) resort.
But the idea would be to compare the content of the Files/Data folder of the last functional backup with the crippled version’s side by side.
And whatever the crippled version would have as a “3B4E76A8-330F-4077-B8C9-CD875D3020A8” folder that the last known functional version doesn’t have, you’d copy to a third “recovery” folder.
(You could also compare common files/folder’s size or modified date to spot pre-existing binder documents to which you would have added content between the two versions.)
After which you’d one by one open these RTF files [content.rtf] (using a third party app - say the Mac’s equivalent of WordPad or NotePad) and copy the content back to the last known functional version of your project (in the editor - as if you just typed them in for the first time) as new binder items / documents.
You’d have to paste them in using paste and match style so that you ditch the formatting and all, making sure you don’t carry back in whatever corrupted the project to begin with.

As I said, not a simple task. – Painful, even.
(Likely, any and all of alternative fixes that may be suggested will be better than resorting to this. But in the event that all else fails…)

P.S. You could also do the same thing, but without doing any comparison between the two versions, simply copy the whole of the content.rtf files from the crippled version to a brand new project. (Again: first opening them, and copying them to the clipboard, using a third party app, then in a new scrivener document, in the editor: paste and match style.) And start fresh from there.
You’d then have salvaged all of the content, but would have a complete project to rebuild/organize.
It’s only a matter of knowing how important to you is the content’s difference between the two versions. As in: how big of a loss would it otherwise be?

Again, as I said : last, very last resort.
(If it ever comes to this, make sure you don’t mess up your last known functional version. Be sure to have that backup of it safe somewhere. Don’t do such gymnastics right in the only version you’d otherwise have.)

This method is likely to receive Literature & Latte’s seal of disapproval.
. . . . . . .

Did you try this ? If my memory serves well, this often fixes things such as your issue :

Good news to everyone who posted here: Dirkhaun’s suggestion to follow the input at Resetting a Project's Display Settings / macOS: Troubleshooting / Knowledge Base - Literature and Latte Support worked! I deleted the ui.plist file from the settings section of the corrupted project and the project was able to open!

It had to rebuild the Index, which took a while, but that’s fine: everything is still there from the day it got stuck.

Thank you all for being so responsive in the lead-up to the New Year’s weekend.

Have a great 2023!