Can't open some Mac files in Windows trial

I use Dropbox to sync between my Mac desktop and laptop to great success. This weekend, I rebuilt my old HTPC using Windows 10 and installed the Scriv Windows trial with the plan to use it as a writing station (Only running Scriv and a browser, maybe an image editor).

I’ve successfully synced Dropbox so all of my files appear on the Windows machine. Strangely, I can open older Scriv files, even files I haven’t used in a year or so. But the newest Scriv files, the ones my current work is in, won’t open. I was concerned the sync was keeping a lock on them, but I’ve created new versions, opened and closed the files on my laptop (the computer I was working on previously) and even rebooted my laptop. They will not open.

I’m not getting any errors. Scrivener simply doesn’t open the file. I’ve tried all three methods including double clicking the scriv file in the folder, using File>Open and selecting to open a file from the splash screen. Double clicking on the file at least causes the open command to go to the trial software, but the other two options do nothing. It’s as if no command has been requested.



Tested more and discovered I can open one of two on my desktop Mac, but neither on the Windows machine. I was able to create a blank file and copy all of the contents from one file. The new file can be opened on all three machines. At least, to this point, I’m able to use the file on any of the machines I prefer.

I’ll test some more to see what the limits are.

The problem you’re seeing is usually the result of a sync conflict resulting in multiple copies of a file or “conflicted” copies. I’d make sure you have a backup of the project (you can right-click the .scriv folder and choose “Send to \ Compressed (zipped) folder”) and then take a look through the contents to remove any conflicting files. (If you’re doing this on the Mac, you’ll need to right-click the .scriv file and choose “Show Package Contents”.) You can just move them somewhere outside of the project rather than deleting them, in case any of them are actually versions of text that you want; you can drag them into the project’s binder after it’s cleaned up to import them into the project and compare it to the other copy.

Thanks for the advice. That’s what I was doing and it is working. This morning, I tested a few more files on my desktop Mac and was able to replicate getting the error that tells me a file is in use on another computer. I’m still not receiving those warnings on the Windows trial version. I’m not sure if this is a Windows thing or a trial thing, though I’m guessing the latter (for no other reasons than guessing).

I spoke too soon. The file I want to work on today, project #2, doesn’t appear to be locked between my two Macs, but my Windows Trial will not open it. I’m back on my laptop to create a copy and sync it though Dropbox. I did finally get a message from Windows Scriv telling me it was in use by another program. I told it to make a copy and it presented the Try/Buy/Register screen. After clicking Try, it did not create a new copy and only presented the splash screen. Further attempts to get the Try/Buy/Register screen did not work.

An hour lost just trying to get a sync that works.

Created a new copy and moved all of my files over to the blank version, which does open. Here’s the interesting bit, which I just tested. With the file that would not open, it didn’t matter if the Windows Scriv trial was open or not. Except for the one time, trying to open the project resulted in no action from WSTrial.

With the “clean” copy, it doesn’t matter if WSTrial is open or not. Either way, it opens the project. If WSTrial is closed, I only receive the request to Buy/Try/register. But the project still opens behind that screen.

Keep in mind I was able to open the original project between my Mac laptop and Mac desktop with no problems. But I had to create a new file to sync and open on Windows. There must be some code somewhere keeping the file from opening.