Can't open zip files created by the automatic back-ups


First, there is no drama yet: I have not lost anything. I don’t need to go back from a back-up file. I just thought that I had too because of a smart quotes conversion problem when switching between Mac and Windows (I’m still trying to find a solution to this problem, if you have any idea).

I use Scrivener on both Mac and PC. Project is saved on Dropbox and backed-up automatically on the local hard drive on each side on project close—to be sure I can revert back to something if there is a problem on project opening on the other side.

I just tried to open one of the zip file created by Scrivener (Windows version) and was a little worried to get this message with 7-Zip: screenshot here.

The only thing it managed to extract is a file named exactly “ThÞse.scriv”. The original one is was named “Thèse.scriv” so I guess there is some kind of problem with the ‘è’ character… Is it what is causing the rest of the problems? I mean being unable to unzip the file. Should I rename my project to remove this character?

Am I doing something wrong? Is it possible to make sure that Scrivener can deal with the special characters?

I’m a bit worried here.

Any help appreciated. Thanks.


7-zip is known to have issues with lots of .zip compressed archives, Scrivener’s included. I’d suggest you just ditch it; Windows comes pre-installed with the ability to extract files from a .zip archive anyway (and to create them too). If you want a more robust interface, winzip will work.

OK, I seem to be able to get inside the archive correctly with just Windows Explorer. I can then copy the files somewhere else and open then back in Scriver (by the way is that the correct way to revert back to a backup file?).

Only thing, though, is that Scrivener still can’t handle the ‘è’ character in the backup process or something. The backup’ed file is still named ‘ThÞse.scriv’ instead of ‘Thè’.

Could that have some effect somewhere else in my project or do you guys think it is just the project name? (So far I all the French accents, etc., seemed OK inside the backup.)

Thanks for helping me—I’ll try to find a 7-zip replacement.

Ever since Sinclair ZX80 computers, it has always been a terribly bad idea to use special characters in filenames.
Use and get done with it. :slight_smile:

Thanks for the information about 7-zip and ZIP files created by Scrivener. I hadn’t been aware of such a problem. I’ve used 7-zip with them successfully so far, but no matter – no point tempting fate. I will update Winzip/Wzzip and use them instead. I suppose I should also look into WinRAR and RAR. Windows’ “native” ZIP features are useful, but running those processes unattended would probably require using PowerShell, which I’m less than enthusiastic about learning at the moment.

I was surprised to read that some were experiencing problems with 7-Zip. I began using it about seven years ago when I encountered problems with Windows’ default ZIP archive tool mangling nested directories. Since then I’ve never had any problems with 7-Zip, at least on English-language versions of Windows.

I also note that 7-Zip has been localized into several languages. In, see the left side bar. I mention this because the original poster didn’t indicate if he was using the English version of 7-Zip. If yes, perhaps a localized version might help?

Cheers & hope this helps,

I’m also surprised that anyone’s having problems with 7-Zip. I’ve found it to be utterly reliable and I use if frequently. I’d recommend deleting it and reinstalling the latest version.

I’m also a long time user of 7-Zip file manager and also can’t use it to extract Scrivener’s zipped backup files (compressed or not).

Didn’t really want to install another zip file utility, but found a light-weight, free, zip extractor (only) program that works perfectly with Scrivener .zip files, called Universal Extractor

There’s a download option called ‘UniExtract Binary Archive’ which allows you to create a ‘portable’ version, so you can run it just by clicking the executable rather installing it. :smiley: