Can't paste into outliner synopsis

Scriv version 2.0.2

I’ve recently discovered that when you paste into the synopsis area below the Title of a document in outline mode, the text is discarded when you hit enter or click on another node in the outline.

If I type something after the pasted text, whatever I type is preserved, but not the pasted data.

Note this has to do with the (by default) red text in the outline under “Title and Synopsis”. Copy & paste work fine with the synopsis in the inspector.

I can’t reproduce this, but I might be on the wrong track because the synopsis text in the outliner is grey by default, not red. I’m actually not sure of any text that is red by default.

Here is what I did:

  1. Created a new item with Enter
  2. Type in a title “Test”
  3. Pasted in some text (five words)
  4. Pressed Enter to confirm

This worked both while viewing the outliner, and later on after I switched to some other area in the binder and came back. I also tried clicking somewhere in the blank area of the outliner to confirm, instead of the last step.

I can’t reproduce this either - could you please provide the necessary steps to make this happen?
Thanks,
Keith

It’s still happening to me, here’s how I produced the bug:

  1. Create new project from Fiction->Novel template
  2. Select Manuscript in binder
  3. change view to outline mode
  4. Under chapter, create new document (hit enter while highlighting last “scene”)
  5. Enter name for scene and then synopsis
  6. Copy synopsis from new scene
  7. Hit enter to create new document.
  8. Type in name for newest document, hit ENTER key
  9. CMD-V to paste previous synopsis into newest document’s synopsis field
  10. Hit enter, see the new synopsis disappear.

I opened the Console and searched for “Scrivener”, but no new messages appeared.

As for the red Outliner synopsis text… what setting affects the color? I don’t remember changing it, and can’t find where I might have done so.

If there’s anything else I can do to help track this down, let me know.

I followed these instructions exactly and it still worked fine for me. Which version of OS X are you running? And did you just copy the synopsis by selecting it and hitting cmd-C, or did you select the title too?

I’m on OS 10.6.5

To copy a synopsis, what I usually do is

  1. type one in for an existing document/folder
    2 … hold down SHIFT and use the UP arrow, which brings the selection highlight up into the document name.
  2. I then hit RIGHT arrow to bring the selection highlight back down to only the synopsis.
  3. Then I use CMD-C to copy

To paste,

  1. I click on a document without a synopsis,
  2. move the cursor so it’s after the title…
  3. hit ENTER
  4. use CMD-V to paste
  5. Hit ENTER to confirm the synopsis
  6. The synopsis disappears.

The missing Robert-specific element:
I mapped my Scrivener PaMS to CMD-V and the standard Paste to CTRL-OPT-CMD-V.

If you Past and Match Style, the text you are pasting will appear, but will not “stick” when you hit enter.

So I guess it’s still a bug, in that it should save the synopsis text even if you use PaMS, or it should refuse to display the pasted text if it’s not going to hold onto it.

A-ha! Now I can reproduce it, using Paste and Match Style, every time. Obviously this is a bug - I’ve no idea why that’s not working. There a few outliner glitches similar to this that are on the list for fixing in 2.0.3, so I’ve added this one to the list and will - I hope! - have it sorted for the next update.

Many thanks!

All the best,
Keith