Can't re-apply settings from line-spacing drop down?


For Scrivener for Windows 1.6.0.0.

I’m exasperated! I simply cannot make the line-spacing drop down re-apply a configuration that I’ve specified for text entered earlier in the document.

  1. In Tools—> Options —> Editor, use the drop-down list to specify default indentation and spacing, then click Apply.

  2. In the editor, type some prose. Scrivener (generally but not always) applies the default line spacing. This generally works great for a single uninterrupted flow of body text. However….

  3. Enter some heading text then select it. Because you want the text’s indentation and spacing to be different than the body text, use the line-spacing drown list to specify unique values for heading text, then click OK. Scrivener typically applies the new settings to the selected text.

  4. Enter some text after the heading, then try to use the spacing drop down list to choose the default settings for the body text. Scrivener generally will NOT (re-)apply those settings to the selected text.

ScrivenerLineSpacingDropDownWithExistingSettings.png

  1. Create some more heading text then try to use the spacing drop down list to choose the line-settings you created for headings. Scrivener typically does NOT apply those settings to the selected text.

  2. Start over from scratch: Select the heading text, in the line-spacing drop down choose More, then re-specify the very same settings you specified earlier. Scrivener applies the newly specified settings.

I’ve been using computers since 'bout 1981 and can usually figure out how to trick programs into obeying. But the spacing drop-down list doesn’t behave intuitively if even that. “Flaky” is one word that comes to mind; “annoying” is another one…

I understand that Scrivener doesn’t aspire to be a page layout program. But it’s much easier for me to work with a document file that includes some visual relief in the form of sans serif headings that align just a bit to the left of slightly indented serif body text. Why am I having so much difficulty achieving that with the spacing drop-down?

Cheers & thanks,
Riley
SFO

In short, you’re having difficulty because there’s a bug preventing the spacing from applying properly via the format menu. :neutral_face: This is on the bug list, but in the meanwhile I’m afraid you’ll need to go through the spacing dialog to set the spacing.

Well at least it wasn’t my imagination. Or something I was doing incorrectly.

Cheers & thanks for your help,
Riley