Can't restore from backup

I have a new computer, my files are part of FileHistory, Windows 10 backup system.
I can see them, but I can not open them.
I keep getting errors that I don’t have permission, I changed some files in Properties, Securities, Everyone full control.
I found a older file that I had saved directly, just copying to the external hard drive. It restored OK, Scrivener telling me it had to update the old files, but these are from 12 months ago.
At some point I had the correct files in the binder, but no text to go with it and this could not be saved.
Have I lost the last 18 months of my writing?
Maybe not quite, I did a compile a few months ago and printed that out…
But all my research has gone…

Scrivener v1.9.5.0 and above use a newer file format. Because of this projects created with older versions(such as 1 year old) need to be upgraded when opened with the newer version. All your data will be preserved during the upgrade process, and Scrivener creates a project backup before attempting the upgrade.

Don’t open the file, copy them to some active folder. Then open…

Thank you both.

Answer 1: This worked where I had saved my files simply by copying to the external hard drive. It updated the files automatically. But this is a July 2015 version of my manuscript.
This doesn’t work for files saves through FileHistory. And may I add, even Microsoft’s own .pst files give me the same error message: you do not have permission, in spite of my changing the permissions to ‘everyone’.

Answer 2: didn’t work for me.

I did at one stage manage to get the latest binder back, but not the texts that belong in the binder and I don’t know how I did that.

All I can say is: I am going back to backing up by simply copying the files to my external hard drive and give FileHistory a miss.

My printed compile was done July 2016, so I have something.

Thanks everyone

Hetty :cry: :cry:

To add insult to injury, when I click on one of the Scrivener files, and ‘Open with’ comes up, Scrivener is not on that list and digging deeper using a ‘search for other programs’ it doesn’t come up either.
What I can open is the few snapshots I did in the last month.
I had started the rewrite of my first draft…

A Scrivener project is a folder (name ending in .scriv) that contains multiple subfolders and numerous files and subfiles. You’ll need the entire folder, not just select files from within it, in order to be able to open the project in Scrivener. I’m not familiar with FileHistory, but seems likely you might have to explicitely do some sort of restore of the entire folder out of FileHistory to some other location, rather than trying to access them down in some FileHistory folder.

Sometimes, at user option, Scrivener projects are backed up in compressed (.zip) format as a single physical file. While one can use File Explorer to browse the contents of such compressed material, one has to extract (decompress, unzip) such before one can open and work on them in Scrivener again.

To open a Scrivener project from within Scrivener or to launch Scrivener for a specific project from Windows, one must select the project index file found inside the project .scriv folder, which will have a name beginning with the project name and ending in .scrivx. If there is some corruption in the project, you may wind up being able to view the binder in Scrivener but have documents appearing to be empty/blank. That doesn’t necessarily mean that the document contents are lost, but rather that the pointers between binder entries and actual document files are corrupted.

The various documents making up the project exist farther down in the project folder, under Files\Docs subfolder, in the form of numerous .rtf (rich text format) files. One can search for and salvage from them, but that’s a last resort. The .scrivx index file, which is in XML format, contains info tieing the meaningful document names one sees within Scrivener to the actual numeric .rtf file names in the Windows file system. There is also a search.indexes file, also in XML format, that contains the file numbers, meaningful names and full unformatted text. You would need an XML knowledgeable/capable editor to deal with such… UltraEdit is such (free time limited eval available)… and there are likely some free XML editors out there. Again, this is a last resort, and should only be done on a copy of a project that one can afford to lose, never on a live project folder.

Suggestion… never count on a single form or location for backups and never trust any of them until have actually tested and verified (on a regular basis) them. If FileHistory works, great, but also consider regularly backing up, either from inside Scrivener, or via automation or manual use of File Explorer and such, to other locations such as elsewhere on the hard drive, a second hard drive, and especially to off-the-machine and/or off-site media or locations such as external USB thumb/flash drive, DropBox cloud storage, CD/DVD, etc.

Thank you. I do see all the files you mention. I am going to print out your suggestions and will let you know how it went.

I couldn’t make it work and I have given up trying.
What I did do was start a new project, then import the compile back into it. It isn’t the latest version, but did an admirable job of splitting it back into the scenes I had. This was July 2016, much better than July 2015.
Gives a different meaning to the rewriting, doesn’t it…
Thanks all for your help. I have learned my lesson.

Thanks everyone again, but especially SpringfieldMH for the comprehensive instructions.
I printed your reply and read through it again.
Yes, I have the most recent binder titles, but no text.
Played around with opening .XML files and .rtf files.
As I do have a July 16 version ( thanks to the compile) and haven’t done a lot of work to the manuscript since, I don’t think I am too badly off, but I wanted to thank you specifically for going to the trouble.
Cheers from Down Under