Can't see watermarks

I’ve just started using the ‘Status’ function (first draft, final, etc), but it isn’t watermarked on the files when I show them in the corkboard view. Do I have to switch something on or off? Tried searching the Help for ‘watermark’ with no result.

Oh, found it: View / Corkboard options / Show stamps