Can't select growl notifications for project target

I am having trouble getting Growl working with Scrivener. I just installed Growl 1.3 from the Mac App Store (I am running Lion 10.7.2).

When I run Scrivener (2.1, 14118), I see it show up in the Growl preferences pane, so it seems like it is connecting to the service. However, I have two issues:

  1. If I set a document target and check “Show Target Notifications Using Growl”, the notification never appears when the target is exceeded.
  2. In the Project Targets pane under Options, “Show Target Notifications Using Growl” is grayed out, so I cannot even select it.

In Growl, all of Scrivener’s notifications are enabled and “Stay on Screen” is set to “Application Decides”. I have tried a few different options with no success.

Also, I use Growl with a Pomodoro app and with Ruby on Rails Autotest, and it works perfectly with both.

Any ideas?

Hi,

The first thing I would try is reinstalling Growl and then restarting your machine - the only issue I have ever heard of similar to this was fixed with a reinstall of Growl. If the tickbox is greyed out, then that means that the Growl framework is returning “NO” to -isGrowlInstalled when Scrivener asks it, which indicates something wrong somewhere. I am using Growl 1.3 with Scrivener 2.1 on my own machines, and everything works fine, so the most likely explanation is a bad install, although it’s odd that it’s working with other programs. Certainly, try a reinstall first and let me know how that goes.

Thanks and all the best,
Keith

Thanks for the suggestion. No luck though. I removed growl including the plist files, etc. in ~/Library and reinstalled. Same situation: it works with Pomodoro and autotest, but not Scrivener.

Next I tried removing and scrubbing all of the Scrivener files (plists, etc.) and reinstalling that. Same situation again. The document targets allow selection of Growl notifications (checkbox not greyed), but the notifications do not post, and the project targets window does not allow selection of Growl notifications.

Screen Shot 2011-10-24 at 10.58.45.pngScreen Shot 2011-10-24 at 10.58.31.png

After both reinstall attempts (and even before), Scrivener does appear in the Growl preferences pane.

Is Growl definitely running? Have you got it set up so that Growl is enabled upon login? Is the little Growl paw in your menu bar?

All the best,
Keith

Yes, Growl is definitely running.

Interestingly, I removed Growl 1.3 and found and installed an older version. With v1.2.2, rails autotest stopped working for some reason, but Scrivener started working. I was able to select notifications for the project and session targets, and the notifications posted correctly.

Out of curiosity, I reinstalled v.1.3. Now the option to select growl notifications is greyed out again, but it is still checked, and the session notifications appear. The document notifications do not appear just like before.

All I really wanted was the session notification to work, so I might be at a place where I am satisfied. This is still quite strange though.

Hi,

I doubt this will make much difference, but on the off chance, please try this build:

literatureandlatte.com/dlbet … wlTest.zip

Thanks and all the best,
Keith

I couldn’t help noticing that the words/characters selector was greyed out on the Session target screenshot above. I can’t recall anything that would disable that selection, so maybe there’s a clue to the problem there?

That is greyed out—I think—because I have a deadline set. The deadline is auto calculating words per session.

This build actually does work just fine. With this build, the Growl option in project targets is not greyed out and I get notifications when the box is checked and I don’t when it is not. The document target notifications also work in this build.

I also tested the document save in full screen notification. This works if I save with Command-S, but not on an auto save. Maybe that’s normal.

The draft target notification works as well.

Ah, great! (And yes, the notification is only supposed to show in full screen if you hit cmd-S, the same as how the menu turns blue in the regular editor).

I looked at the Growl framework documentation, and it turns out that calling +isGrowlInstalled, which is what I was doing, has been deprecated in 1.3, and that you should call +isGrowlRunning instead - so that’s the only change I made in this build. Good to know it fixed things!

Thanks and all the best,
Keith

That makes sense. Thanks so much for your help.