Can't select multiple files to change section type?

Ah, thank you, I was trying to:

  1. select multiple files in the binder and then click the dropdown in the Inspector (doesn’t work)
  2. select multiple files in the compile contents list and click the dropdowns there (doesn’t work either)

I’ve created three Section Types in the Project Settings:

When I go back to my project and select a text file in the Binder the Section Type dropdown shows only the following options:

If I click ‘Edit…’ the Section Types panel appears (as the first image above) and I select one of the options (say, ‘Front Matter’), click ‘OK’ and the Section type remains as ‘Section’, and won’t change. The dropdown list remains as above. The same happens in the Compiler dropdowns.

I’m sorry that I don’t sound more enthusiastic at present, as I understand the huge amount of work you have put into the software.
I have to admit that I have something of a love-hate relationship with Scrivener. I love it enough that I even bought a Macbook solely to use the Mac version(!). But that was after a long and painful dawning that the Windows version wouldn’t do what I had hoped.
But most of the new version is fantastic - it looks and feels sleeker and more modern than v2. I just keep finding myself stuck on some problem that seems to take days spent searching the web and forums to resolve.

Once I get these problems out of the way I’m sure will be back to loving writing in Scrivener once again.

The main problem I am having at present is outlined in another forum topic:
[url]How to generate Kindle TOC for chapters without titles?]

If you (Keith) would be able to answer my question on it please, I can hopefully get moving again on my work as it’s driving me crazy:

When Scrivener auto-generates its TOC for Kindle, is there any way to add a text section to the TOC when the ‘Title’ checkbox in the ‘Section layouts’ area of the Compiler is unchecked? As soon as I uncheck it I lose all of my chapters from the Software reader’s TOC.

Many thanks.