Can't set Scrivener 3 as the default app to open .scrivx files

After a complete reinstall of windows, followed by a reinstall of Scrivener 1.9 and 3, I find that when I double click on a .scrivx file, windows wants to open it in 1.9. I have tried:

  • right click ‘Open With…’ and selecting the Scrivener 3 .exe - but this does not work, Windows still opens the file in S1.9.
  • ‘Choose Default Applications by filetype’ - the only options are S1.9 and ‘Look for an app in MS store’.
  • ‘Set defaults by app’ - neither version of Scrivener is in the list.

What do you suggest now?

You might try uninstalling Scrivener 3 and reinstalling it. If I remember correctly, my PC defaulted to the last program installed that uses that file type.


I would also consider after offloading all saves uninstalling the old version of scrivener and then reinstalling scrivener 3 to give windows only one choice to open the scrivx files.

Thanks. Reinstalling worked.

1 Like

Glad you got it going – it’s the order of installs that chooses who automatically becomes default opener.

I think you can fix it without reinstalling, though that is a good move.

There’s the Open With choice if you right-mouse on a Scrivener project file, and from the dialog for that it’s possible to choose another opener, with a checkbox to select that as future default opener.

I’m away from laptop, but I think it gives you a list at first of any alternatives Windows knows about (probably where you found only the one Scrivener).

But there you also have a choice to ‘choose another’, and this will show a regular files dialog where you can locate the Scrivener 3 app executable, and use the checkbox to mark that this should be the automatic opener after you accept.

1 Like

Thanks, but I did all this, and it did not work. I selected S3 in the Windows dialogue, but thereafter Windows still opened .scrivx files with S1.9.
What did work was to run the S3 installer a second time. I did not uninstall anything, just ran the installer. Windows then ran .scrivx files with S3.

1 Like

. . . . . . . . . . . . . . . . . . .

1 Like

Actually, it didn’t work for me either, having had the situation last night.

No idea, but Vincent’s quote of RuthS is definitely the way for Scrivener

What happens if you temporarily rename (or otherwise hide) the 1.9 install, making it unavailable to open .scrivx files? With that done…

Double clicking a scrivx should ask what to open it with. Manually point it directly to the S3 exe file, and be sure to click the “always open with this” option. After S opens, close it, then double click the scrivx again? What happens?

If that works, rename (back) the 1.9 install. Then double click the scrivx? What happens?

I dunno… but that’s what I would try. Setting the default app when there are multiple installs can be tricky.

If that works, then I guess someone could even simpler just ask that his/her Scrivener projects be in the future opened by Mozilla Firefox or any unrelated app…
Then, after a fail (better to stop doing drugs if Firefox or else loads your project properly), to set it back to the desired Scrivener version.

Just theorizing…

I imagine that might just work, too. It’s just a stubborn setting that needs to be dislodged. In this case, both exe files have the same name. I imagine that could be a factor (even though the path to the exe will be different.)

Sometimes, renaming or moving an exe file gets picked up by the system and shortcuts to it get updated. I don’t think I’ve seen that behavior in a long time, but I recall encountering that once upon a time.

I am just not so certain moving an .exe file is such a good idea.

It’s probably not, as a rule or a practice. Won’t argue with that.

Another (and perhaps safer?) approach might be to set the scrivx to open with Notepad or similar, which should succeed, and allow the open-with process to complete without issue. Then changing it back to S3.

@Mad_Girl_Disease , you had a reasonable idea here.

Unfortunately, this situation doesn’t look reasonable :slight_smile:

I didn’t quite try what you suggested, but some other things, and noted:

  • at the point of selecting the new Scriv with always use checked, you can see it trying a moment, but then the choice is reverted by the time you can see your file again to try the double-click
  • There’s yet another way to choose default apps: digging down unreasonbly in the Default Apps section of Windows Settings. But by the time you get to where you could do some good, the proper Scriv3 doesh’t show at all.

My conclusion is that it is either that I only installed Scriv1 as a non-admin user, since it was just for a recent test, thus it is in userland Documents/Scrivener rather than in program files, or more likely, there’s something funny about how Scriv1 originally set up to be available as an icon app – something in registry that overrides normal changes. How it acts, anyway.

I just reinstalled Scrivener 3 as an admin user (to avoid other problems, then switched my user level back for the safety) to fix it, carefully having saved off my Scrivener Options and Theme options.

It turned out that doing this simple reinstall-over didn’t affect those, but it’s still probably a good idea just in case, since it only takes a moment at the bottom of the Options panel.