Can't turn off "Do Not Disturb" in Composition Mode

When I enter composition mode “Do Not Disturb” automatically activates. If I turn “Do Not Disturb” off while still in composition mode the “Do Not Disturb” turns right back on. I do not have “Do Not Disturb” scheduled on my computer. This only happens when I’m in composition mode, not any other time in Scrivener or in other programs.

I recently upgraded my MacBook Pro to MacOS Big Sur Version 11.2.3, and I don’t think this happened before upgrading. I’m not positive about that however, because today I had a specific reason for wanting to turn off “Do Not Disturb” while writing and discovered that I wasn’t able to turn it off while in composition mode.

Here are the steps I took:

  1. Activate Composition Mode (both using the keyboard and the drop-down menu).
  2. Verify that “Do Not Disturb” is active because it is greyed out in my customized control strip (part of my version of the MacBook Pro keyboard).
  3. Turn off “Do Not Disturb” using the button on my control strip.
  4. Watch the button immediately grey out again on its own.
  5. Attempt to turn off “Do Not Disturb” using the drop-down “Control Center” in the menu bar. This button is blue when “Do Not Disturb” is active and grey when not active. In composition mode I can’t get it to switch from blue to grey when selecting it with my mouse.
  6. Ask Siri to turn off “Do Not Disturb”. Siri responds "Okay, I’ve turned off “Do Not Disturb” and shows an image indicating it is off in System Preferences. However, the button in my control strip is still greyed out and the button in the drop-down “Control Center” in the menu bar is still blue, both indicating that “Do Not Disturb” is still active.
  7. Verify each time that “Do Not Disturb” is functionally active as well by having my husband text me so I can verify that I am not getting notifications while in composition mode.
  8. Reconfigure my control strip so it does not include “Do Not Disturb” and try steps 5-7 again, with the same result: I can’t not deactivate “Do Not Disturb” in composition mode, nor can I receive any notification in composition mode.
  9. Test outside of composition mode, both within Scrivener and without, and verify this only happens in composition mode.

I would like to be able to use composition mode and receive notifications at the same time.

I wonder if this is a bug in MacOS.

I’m running Scrivener 3.2.2 on MacOS 10.13.6 (yeah, I know, but I don’t have the budget to upgrade my Mac mini to something that can run a new MacOS.) When I enter Composition Mode, it turns on DND, but if I go turn it off manually, it stays off. If I turn it back on manually, then exit Composition Mode, DND stays on.

This is the darndest thing. I seldom use Composition Mode, but as far as I can tell, it has no effect on Do Not Disturb whatsoever. I can’t wait to find out what’s going on.

Scrivener 3.2.2, MacOS 10.15.7