Can't using Courier Prime in Russian

Hi,
I found some trouble with Courier Prime Font in Russian language. Russian is default language on my Mac. I have installed cyrillic version of Courier Prime that works correct in other apps (Pages, Numbers, etc.) but not in Scrivener. When I start typing in Russian the font automatically switches to Monaco. Even If I select block of text and set Courier Prime nothing changes. Other Russian fonts work correct. How can I fix it?

Could you please provide the exact steps necessary to reproduce the issue? Are you working in scriptwriting mode or just typing regular text? If in scriptwriting mode, have you updated the scriptwriting font as necessary via the Script Settings?

All the best,
Keith

I would also run a check using TextEdit under the same conditions as Scrivener. The text engine in Pages is almost as far removed from what we’re using as Word or LibreOffice would be.

My steps:

  1. New Project
  2. Screenplay Template
  3. New Text in Screenplay folder or start editing an existing.
    4.Type any symbols in Russian

The same problem appears with every text element, in Blank template too.

Each element in Script Settings has Courier Prime as a font.
screenshot: https://www.dropbox.com/s/8n5sc20eq27nhhu/settings.jpg?dl=0

In TextEdit font works right.
https://www.dropbox.com/s/pf35x4857znsl0m/other_edtitors.jpg?dl=0

Hi! I’m having the exact same problem in screenwriting mode.
I’ve been using Cyrillic version of the Courier Prime font in other text or screenplay editors (TextEdit, Fade In, Word, Pages etc.), but Scrivener is the only app so far that ignores it and changes to some substitute font.
Luckily, Fade In can import Scrivener files so I’m able to do my final edits with the Courier Prime font there. Still, it would be great to write using this font in Scrivener as well.
Is there any way to fix it?