Capitalisation.

Probably something I’m doing wrong, but frustrating none the less.

As a playwright, my Act, Scene, Directions and Character Names are all in CAPS, which is as it should be.

Occasionally, however, during editing, the dialogue suddenly converts to caps as well. I’m sure it’s to do with the styles, ie: somehow or other I’m editing dialogue in a scene heading or technical directions style.

I accept this is probably me, but this can be a major headache especially in (as I have been doing a lot of recently) monologues, because the ‘undo’ won’t undo this odd change to caps in these instances.

The result is a whole monologue in capitals which I can’t undo.

It’s at times like this I really wish there was an option in the convert submenu to convert to upper and lower case. There is convert to caps (upper case), convert to lower case, even title case, but no option to convert to what I’ll call ‘sentence case’ ie: a capital letter after a full stop.

I end up having to convert everything to lower case, then manually capitalise the first letter at the beginning of every sentence - Oh and then once I’ve done it, I invariably end up editing some other word at a later date only to find it goes all caps on me again!

Since I can’t ‘undo’ it, I’m wondering if maybe it is some sort of bug. I’ll try and work out how to easily reproduce it. I seem to be doing it often enough!

Anyway, any help appreciated.

Thank you.

It’s a little difficult to say what is happening without more information, I’m afraid. If you convert an element in script mode to an element that has all-caps, you should still be able to hit “Undo” to undo it. Keep an eye on the exact sequence of events that led up to this happening the next time it occurs and let me know the exact circumstances. I use a stageplay-like format myself for some scriptwriting I’m doing at the moment, and I haven’t come encountered anything like this, which is why it is difficult to gauge what is happening.
Thanks and all the best,
Keith

I’ve experienced the same thing. It even happens in part three of the tutorial.

Scrivener asks us to click inside a line of text to show how it can change from general format to screenplay mode. Depending upon the selections (Action, Character, for example) the text automatically switches to ALL CAPS.

If you’re paying attention, no worries. As suggested, you can always click edit undo. No more CAPS. If, however, you’re distracted and start typing away before you realize the formatting change, you’re stuck. You have to re-type everything into lower case letters.

Food for thought.

Thanks.

I think what you are talking about is different - what you are talking about is intended behaviour. In scriptwriting, certain elements should be in all-caps, so if you convert some text to that element, it will get converted to all-caps. The op was talking about a strange situation (he never got back to me and no one else has ever reported it) in which this could happen when it wasn’t supposed to.

All the best,
Keith

I’ve studied my problem a little more. I am a playwright. I use the scriptwriting stage play UK format. I have edited the styles.

I have creative bursts. During dialogue there can be pauses, new paragraphs, stage direction etc, and all even during the speech of one character. When trying to get the speech typed out as quickly as the characters in my head are talking it can be difficult not to mention disruptive to the flow to remember whether I need to tab or enter or whatever combination to change styles. Different combinations are needed to change between dialogue, or stage directions or new paragraphs in either. Sometimes you hit enter to change to character X when you realise char Y buts in and is saying something else, so you tab again to get the cursor to dialogue position again. Of course if you knew X was just gunna keep talking you would have hit tab to get a new paragraph. And of course there are even times when characters are chatting so fast, I just keep tabbing knowing I can type their names in later.

After such creative bursts , which may be a whole scene, I go back and edit. Making sure that the stage directions are indeed stage directions and the character names are all their etc.

This is when my problems come. Click a paragraph and change it to stage direction. It changes. but because I typed a tab during the creative burst, that paragraph is linked to the following paragraphs as they were all part of one characters speech. Now three paragraphs are stage directions. Hit return between after the first paragraph to force the rest back to dialogue, and bang, the first of the two paragraphs become a characters name - IN CAPS - and the second becomes their speech.

This is just one of the main scenarios that can cause CAPS to appear during editing when you don’t want them. Even if you have been meticulous in making sure you typed everything correctly in the first place and simply want to change something.

There is nothing wrong in this. It is not a bug. It is just simply very frustrating. One point where technology and the creative process clash.

Couple that with, the undo feature. Yes, undo change element style works, the dialogue goes back to stage direction in the 2nd half of the example above, but THE CAPS STAY, since you are undoing the change in style, not the change in case. I have to admit this does not happen every time, which makes it even more annoying and difficult to pinpoint for bugging purposes. Even if it does undo back to stage directions correctly, it’s still wrong since you wanted it back to dialogue, which means working out where to put a tab or a return so that you can get it back without it converting to CAPS for the character name.

Okay, so you’ve got confused, caps all over the place since the undo didn’t undo caps, and now you’re lost in the editing and can’t remember who was talking! You highlight a sentence to return it to lower case, missing the first letter that will remain capital. And, oops, the whole sentence is converted to lowercase, ignoring your highlighting, and you end up deleting the first letter, and typing a capital. Adding to the frustration.

Hence my request for a simple ‘Convert to sentence case’ in the convert text menu option. A simple rule stating that there be a capital letter after a full stop, and preferably the capitalisation of any single 'i’s too.

During the creative process and trying to make sure I do at least make the effort to get to use the short cuts etc for changing styles, I have found that using the keyboard shortcut for changing the style does not work in full screen mode. I just get the capital of the letter I am typing with the ‘fn’ button.

Incidentally this is not clear in the pop up menu at the bottom right of the edit window screen. I have set my Character & Dialogue short cut to ‘x’ and my Stage Directions to be ‘z’ since they are nearest to ‘fn’ key. It took ages for me to work out that this is the button you have to push with the letter in order to get the shortcut. (ie not ‘cmd’ or ‘alt’ or ‘ctrl’ or ‘shift’ or indeed any of the permutations!) This is not shown in the menu or mentioned during the setting up. Admittedly I am new to Mac and maybe it is a given assumption that any keyboard shortcut uses the ‘fn’ key by default. I don’t know.

Also when using this scriptwriting stage play UK format, I found this odd behaviour during my editing of the caps problems above. When editing the end of a line, I found that instead of getting the cursor at the end of the line after the full stop, it would jump down to the beginning of the blank line below.

It has taken me ages to work out what is happening here. And I can now easily reproduce it.

Type char name. Hit tab. Type a sentence or two of speech. Hit tab, to begin a new paragraph in that speech. Type new paragraph.

Now place your cursor in the the middle of the last word of the first paragraph. Use the right arrow key to move the cursor letter by letter to the end of the word so the cursor is now before the final full stop of the paragraph. Now hit the arrow key once more. Instead of the cursor going to ‘after’ the full stop as expected, it jumps down to the beginning of the blank line below. If you hit delete, it does delete the full stop as expected, but this odd behaviour is very disconcerting, and has taken ages to work out what was going on.

Ramble over (I’ve done this twice now since my session expired the first time! - Now using edit and will cut and paste!)

Many thanks Keith. Keep up the good work! This software is a god send for me!!!

PS: I have something for the wish list useful for us playwrights - will try and see where I can post it!

Hi,

Regarding the pop-up button in the bottom right - actually the letter shortcuts aren’t meant to work with any particular modifier key; that they do work with Command or Function is an OS X feature that depends on the version of OS X you are using. The keyboard shortcuts work on their own when the menu is opened - if you open the pop-up menu, in your case you could then just hit “x” on its own to change to Stage Directions. This is why there is the cmd-Y keyboard shortcut to open the menu without clicking on it - so you can hit cmd-Y to open the menu (in either full screen or the normal mode) and then hit the letter in the menu that corresponds with the element type you wish to select. And this is in fact covered in the “Scriptwriting” section of the Help file:

As for the other stuff, as you say, I don’t think there’s much I can do about it, as it is all intended behaviour and you would find the same problems in any scriptwriting app. I would say that you shouldn’t hit just tab to create a new dialogue paragraph, though, even for the same character, or you will indeed find that they act as one paragraph. Instead, hit return and then tab.

As for the capitalisation - I’m still not sure why undo wouldn’t work in the situation you describe. When the style is changed and capitalisation is applied, undo should remove both the caps and the style. So if you can find a particular case in which this happens, let me know. I’ll consider sentence case for a future update.

Thanks and all the best,
Keith

Aha! Excellent! Many thanks, Keith.

Except “C” is set for both “Character” and “General Text (Centered)”.

I have the same issue with undo not working when I need to undo an automatically changed caps. Also, when you change the style but don’t change anything and go back to style one, the [Tab] and [Enter] actions are still set on the second style’s settings in many if not all cases.

(I just started dabbling with the Screenwriting mode on Christmas.)

As I say, if you have these problems, please let me know the steps to reproduce, as I have never seen the problem where undo doesn’t work for capitalisation. Likewise, I’m not sure what you mean about the second style still being set or something.
Thanks,
Keith

The Undo key doesn’t work for me either. I mainly work in Scriptwriting. The problem most often occurs if I split a speech to insert a line from a different character. If I then add the first character’s name at the beginning of the split speech and hit return, everything becomes capitalised. Undo doesn’t work.

I see the logic of why the capitalisation happens (my mistake). It would help if there was a command to turn selected text into “Sentence Case”, lower case with a capital letter after a full stop.

Hi,

I still can’t reproduce this, and Scrivener doesn’t reset undo so I’m still baffled. Could you please post full instructions? In particular:

  1. Are you in scrivenings mode or viewing a single text?

  2. What script format are you using?

  3. What do I need to type, exactly, to see the bug myself?

Thanks and all the best,
Keith

P.S. I have seen your other thread as well and will take a look at it - I’m just on my way out.

OP here,

Glad someone else is experiencing the same thing.

  1. Either

  2. UK stage format, though it’ll probably happened in any of them where the Char name is in caps.

  3. Type a scene quickly. Don’t worry about changing styles as you go since the dialogue is flowing and you can always edit the text to become stage directions, or even add directions later. Just make sure that you keep the paragraphs of your char’s speech are linked to each other by tabbing at the end of each para.

Once you have completed a page or so, go back and edit.

What happens is, as soon as you break the paragraphs to introduce or edit something by inserting the cursor and hitting return, that part of the speech will drop down a line and be the beginning of a new char & dialogue.

Make a change even as small as deleting or adding a letter, and the whole sentence, and all the paragraphs following, since they are now part of the new char & dialogue, will change to CAPS

This is because Scrivener thinks all that text is the new characters name, and as such capitalises it.

Immediately undo and you might be lucky, type the next letter in the word you were editing and you are doomed.

Scrivener will undo everything you have ‘done’ but it won’t recognise the change to CAPS since you didn’t do that. Scrivener put it in CAPS because it was Scrivener who assumed it was now the character’s name.

So, it’s not a bug, just Scrivener behaving as it should.

Trouble is, as writers, we don’t write our scripts always changing styles etc as we go. Most of the time yes, but not all of the time, and the faster we write the less changing we do. I will often just Tab in the middle of a speech for a character and type a stage direction.

When I come to edit later, I’ll change it to the Direction style, and of course that’s where the CAPS problem can arise - amongst other places.

As soon as any dialogue you have typed ends up at the very beginning of the line during editing, Scrivener thinks its a Characters name and capitalises.

All I can ask for, and now Ian has too, is the addition of ‘Convert to Sentence Case’ so that when I end up with all caps, I can easily get it back, rather than going through what could be a whole monolouge, editing the text sentence by sentence, just because I was writing too quickly.

Thanks Keith!

PS: For reference, TextWrangler has a convert to sentence option. Sometimes quicker to cut and paste the text to there, convert, then cut and paste back into Scrivener.

Hi,

I’m happy to add a “Convert to Sentence Case” feature, although I am concerned that that there might be differences between languages. Would lowercasing everything and then capitalising the first letter after a full stop, question mark or exclamation mark be enough? Actually it’s a bit more involved that that… It would probably need to use similar logic to the current auto-capitalisation feature. And there’s another problem - should “i” be capitalised? Not in Latinate languages - I could make it so that it only capitalises if the preference for it is turned on in auto-correction, but what about users who turn those off and want Sentence Case to work in English? Hmm.

I still can’t reproduce the issue, though. Here’s what I tried:

  1. In UK Stage Play Format,

  2. I typed some character & dialogue text.

  3. I then clicked in some dialogue and hit return.

  4. The dialogue was placed on a new "Character & Dialogue* line.

  5. I started typing.

But only new text was capitalised - existing text didn’t get changed.

What am I missing? Can someone please provide step-by-step instructions so that I can see it for myself?

Thanks and all the best,
Keith

In UK Stage Play:

  1. In Character & Dialogue, enter a character name. Make sure this character name is also in the auto-complete list or that this adds it to the list.

  2. Hit tab and enter some dialogue.

  3. With the cursor inside the dialogue, hit return twice.

At this point, the dialogue after your cursor is all added (well, the first so many words) to your project auto-complete list if that option is ticked in the Script Settings for dialogue.

  1. The cursor should now be at the start of a line with the chopped dialogue. Begin typing the character name–auto-complete should offer it as an option.

  2. Hit enter or tab to accept the auto-completion, and the following dialogue is all capitalized. (Also if you hit escape twice to select the auto-completion).

If you don’t select the auto-completion and just type it all the way yourself and hit tab, or if your character name is not in the auto-complete list, the following text isn’t capitalized.

The capitalization happens even if you only hit return once in step 3, but I was also pointing out the way it adds the text to the auto-completion list, and that only happens if you hit return twice.