Capitalization in dialog

I am writing dialog for a novel. If I have a period, scrivenir capitalizes the next word. If I have a comma, it doesn’t.
My problem is with a question mark, or an exclamation mark. Scrivenir capitalizes and I don’t want it to.
Example: “What’s new?” said Tom. The word said should stay lower case. I tried to turn this off in Preferences, but nothing seems to affect it. Am I doing something wrong? Or is it a bug?

Just to confirm : you are in scriptwriting mode right ?

No. I am writing dialog for a novel. So maybe that is standard text editing mode?

image

That is exactly what I have in settings. If it isn’t clicked, it should stop this capitalization, but on my machine, it doesn’t. Mac OS 10.15.7

Could it be a setting in your OS then ?
Some ease of … setting ?
(I am under windows. That’s as far as I can go.)

Technically, since you ain’t in script mode, that’s all I can think of. Normally, unless I am mistaking, whatever you type should all be lowercase.

About you try in some other writing app ?

Found it :

Inked2022-03-20 18_38_01-Options_LI

[EDIT] This is weird, first time I checked the option, it did capitalize. But now it won’t.
:man_shrugging:

I am now as confused as you are.

Perhaps try checking the option to capitalize
image
then ok.
Then restart Scrivener.
Then uncheck the option.
Then OK + Restart Scrivener again. ??

If I uncheck fix spelling as I type, and also uncheck the Capitals, then it works fine. I’d rather sacrifice the spell checking. I can always go back and fix that in Hemingway or something else.

In theory :
image

you are only sacrificing “spell fixing” ; not “spell checking”…
You should still have misspelled words reported as such.
So you may fix them manually as you go.

You could also leave things as they were, and take for habit to type ?, and !, when needed,
to then replace ?,_ for ?_
!,_ for !_
at compile.