Capitalization of I when writing other languages than English

Capitalization of “I” is as far as I know only a feature in English, In Danish “i” means “in”. Capitalized “I” does mean plural “you”, but lowercase “i” is far more common. As such, autocapitalization of “I” should not be on when writing other languages than English.

Turn it off at File->Options->Corrections.