Center Text

Sorry for what seems to be such an easy question, but I couldn’t figure it out correctly.

While writing in Scrivener, (not in full screen mode), I usually have the split screen on, but when I return to just the one screen, it flushes everything left with a wide margin of empty space to the right. I tried page layout and a few other searches, but I can’t get it fully centered, as in the body of the story centered fully on the screen. (Not of course the simple center text command.) How can I complete this? THANK YOU!

Does it look like the problem in this post? If so, it may be the same issue.

Yes… it appears the same issue, though I couldn’t enlarge her screenshot, but it looks the same. I haven’t had or seen a resolution to the problem as of yet. Thank you…

The problem in that linked thread appears to be a set right-indent. It could be the same in yours–in a vertical split screen, you might not notice that the indent is set since it could be at about the same place as the edge of the editor anyway, so it may look the same as wrapping at the edge. With the split closed, you’ll more easily see the indent. I posted a reply in the other thread with a screenshot and instructions for removing the indent; I hope that works for you!

It works for Novel Writing, but it doesn’t seem to center correctly for Script Format. It does cover the entire page, but that would be incorrect. Anyway to keep everything neatly centered for that format? THANKS!

Script formats usually have very specific indentation set, both right and left, so text wouldn’t typically stretch across the screen the way it would when there’s no right indent. You wouldn’t want to adjust those, since the indentation is part of what defines the element and is part of the final product, preserved through compile to maintain the correct script format.

If you’re not writing a script in a particular format but using the script mode for something else, e.g. a quick way to flip between paragraph formats for your own benefit, you could play with those settings and remove the right indent from all the elements. That should allow them to wrap to the right edge of the editor. Indents won’t be removed from existing text when you change the script settings, so you’d need to select all that in the editor and then remove the indent by dragging it off the right edge of the ruler.