Centered lines too long after compile?

Hi, I’ve been trying to compile, specifically to PDF using a custom project format based on the paperback 6"x9" template, and everything is formatted correctly except the centered lines in the body of the documents. They seem too long, trailing down onto the next line. I don’t want to have to go through and shorten and re-align these to center manually as there are a ton of them in the manuscript. I’ve previously compiled the same manuscript to .epub with no issues, so I’m guessing it is a problem in compile itself? I’ve searched through the internet, your forums and Reddit with no luck. Maybe I’m missing something so simple? Anyway, please would somebody be able to help? thanks

If you are talking about literal line segments (not lines of text) then it sounds like your custom compile format has set some custom Separators that you need to adjust.

Get into the editing dialog of your compile format and look at the Separators section. You will need to figure out which of the subareas there to look at. Any section types that appear in bold are your prime candidates. (For example, if these separator lines appear between the end of a chapter and the start of the next then you might look at the setting for ‘Separatos before sections’ setting of the Chapter with Title section type.) One (or more) of them will have a custom separator set – to what is probably a long series of m-dashes. You just need to reduce the number of m-dashes used.

That’s my guess!
P.S. Welcome to the Forum, Laura.

1 Like

Thanks for the reply, gr :slight_smile:

Sorry, I don’t understand :confused: i think the terminology is confusing me still, as i’m very new to compile! I was going to try and share some images of what I see but i’m not allowed to yet as my account is so new!

The “centered line” I’m taking about is inserted into the project in various places through “insert”, “horizontal line”, “centered line”. So I think you’re right, I need to reduce the length of this, but I can’t see a way to do it?

Strange, those “lines” should in theory work with even the narrowest compile setting provided, which is the Paperback format even smaller than the one you are using. Did you change the paper size or maybe the font size in the Format?

Well, presumably whatever change you made, it is necessary. Probably the simplest way of shortening these lines is to use Replacements. Though if you styled these lines (which you should consider doing the next time, if you haven’t!) you could also just add an entry into the Format’s style pane that shrinks the font size, and thus shrinks the line, though that may not have been necessary since styles can preserve the font size, meaning this never would have been a problem in the first place.

Here’s the messy brute force way though:

  1. First, go into the text editor and select one of the lines entirely by putting the cursor at the very end, and pressing ⇧⌘← to select to the beginning of the line. Copy the text.
  2. Open File ▸ Compile... and double-click on the compile Format you are using, in the left sidebar, to edit it.
  3. Select the Replacements pane in the compile format designer, and create a new row with the + button.
  4. Paste the line you copied into the first field. You won’t see anything—that’s because this “line” is actually a 100 non-breaking spaces with the underline formatting turned on. Outside of formatting, it’s just 100 non-breaking spaces.
  5. Into the second field, paste again. This time, with the cursor at the end, press the delete key maybe… ten times. The percentage that wraps over on the next line will give you an idea of how much to delete, but it’ll be easier to delete in smaller amounts and test it, than to go too far.
  6. So with that in mind, click the Test button in the lower left.
  7. Still wrapping around? Delete ten more of them. Rinse and repeat until it falls back on one line.
2 Likes

Thanks AmberV, this was exactly it!! I Don’t think I changed anything? And the replacement was an easy enough fix :smiley: Thank you so much!

2 Likes