Changes to compile format don't stick

I’m not sure if the bug here is in Scrivener or in my brain, which tends to seize up when I examine the Compile pane. But anyways…

I have defined a Compile format named Textbook. (Guess what I’m working on! Now you understand my brain state.) I want to make minor changes to it: insert hierarchical numbering before section titles. I make the changes, then press Option to make visible the Save button. I click to save the changes, and the compile pane closes. Everything seems fine. But when I now go to compile for real, the pane now comes up with Custom displayed as the format. The changes I made still exist here, in this (unsaved) Custom format. But if I switch to the Textbook format, the changes do not display there. They haven’t stuck!

That’s because you haven’t updated the Textbook format. To explain:

  1. You created a Textbook format.

  2. You then made changes to the Compile settings and saved them.

  3. Now, the compile settings no longer match the Textbook format - they are a modified version of it. Thus, Scrivener shows “Custom”.

To see why it works like this, imagine you load the “Novel” preset and change the “Quick Font Override” to use Times New Roman. You wouldn’t want the “Novel” preset to be forever changed when you load it in any project in the future just because you made one amendment to the settings in the current project.

Thus, if you make changes to your compile settings that you want saved into your compile preset:

  1. Select “Manage Compile Format Presets…” from the “Format As” menu.

  2. Select your preset in the list (e.g. the Textbook prest).

  3. Click “Update”.

This will update the preset so that it is now based on the current compile settings.

I hope that makes sense and helps.

All the best,
Keith

Thanks, Keith! That makes perfect sense.

This bug has now been fixed in the latest beta of my brain, available for download shortly. It will be included in the next update of my brain, available at no cost to current subscribers.

:smiley: