Changing default General Meta-Data status

Ugh. I just added a new piece of research to my project file this morning… a definition of a word including synonyms, so I wouldn’t have to dig out a Thesaurus every five minutes. Unfortunately, the “Add as text” feature added everything on the webpage, including advertising and other word definitions I did not want. So I deleted everything but the text I wanted, not thinking anything of it.

I go back into my writing pane and check my project target data, just to see how much I’d gotten done so far. I was 600 words into the negative! It took me a while to figure it out, but not only had the research item been automatically marked “include in compile” by default, but that deleting all that extraneous crap from the import had screwed up my word count for the day’s work so far.

Is there a way to set the program so that all research, by default, is imported and added with the “include in compile” box UN-checked? Assuming that will work around this little quirk.

I set very specific goals for myself, and I shouldn’t have to struggle to remember what yesterday’s final word count was, and do math, to figure out where I was before this snafu happened. Maybe it’s my fault for importing it as text, instead of just as a web page, but I also have an ISP with a bandwith cap, and I didn’t want it to go pinging out and downloading data each time I had to choose a synonym for a word I was going to be using that often.

We do indeed have plans to add options to the session counter in the future. Amongst them will be two options that would directly impact your concern:

  • Count text written anywhere in the project. This will be off by default, meaning the session counter will only increment (or decrement) in the Draft folder.
  • Allow negatives. On by default, disabling this would avoid the -600 issue, but you’d still get subtractions on edits.