Changing Font

I set the default notes to Times New Roman. And the at the top Text -> Font to Times NR, and whenever I start a new note it reverts to Optima 13

The notes font in the Preferences refers to the notes in the inspector. You need to change the font in the “Default Main Text Attributes” at the top of the Preferences > Text Editing tab.