Changing preset formats

Hi all. I’m using Scrivener in Screenplay mode to write a movie script.

At the lower right corner of the text area, I find a popup menu containing a number of preset text formats, such as Dialogue, Action, Shot etcetera. After writing quite a lot, and comparing with actual existing movies scripts, I think that some of the indentations and margin settings should be altered.

How do I access the preset formats and edit them? Can’t find them anywhere but in that popup menu…


Hi, Eldberg, and welcome to the forum.

You may try Format > Scriptwriting > Script Settings
[this is for the Windows version, Mac may be a little different]

However, Scriptwriting is (IMHO) an advanced feature. I’d suggest you go through the tutorial at least once to get a grasp of the whole thing before you fiddle with these settings.

Good luck!

It’s the same place on the Mac. Indents and line-spacing are set up in the Paragraph tab for each element within the Script Settings window.

Do note that our default screenplay settings are “Hollywood standard”, so unless there is a regional difference they should be okay. Another thing worth noting is that Scrivener is not a page layout program, it doesn’t have a sense of margins in the software while you are writing—these are added later when a document is created out of the project with the compile function. So all of the measurements will be one inch off in the editor, and in the settings.

Thanks. I found the settings. Can’t understand why I didn’t see them before…

Was a bit disappointed though. I changed the right indent of the “Dialogue” preset, but instead of applying this to my dialogue paragraphs, Scrivener seems to have converted them to “General text”. Which means I shall now have to go through 80 pages of text and reapply “Dialogue” to every such paragraph.

Another thing that I would put on my wish list is an automatic recalculation. The settings here are in inches, I’m metric. But if I select centimeters, the numbers stay the same; if that was applied, it would be disastrous.


It does look like there is a problem with the conversion. I tried this on a sample text and got General Text as well. I set the right-indent to 6 inches instead of 5. Fortunately, since nothing actually changed about the dialogue text formatting, I could set the settings back to 5 inches and it went back to recognising dialogue as dialogue.

What I just said there ought to explain why there is no “automatic recalculation”. Scrivener is an RTF editor, not a dedicated scriptwriting program. The text does not have Dialogue assigned to it, it is merely recognised as Dialogue because it precisely matches the definition of what a dialogue line should look like. Change the definition (or the formatting, using the RTF tools) and it will no longer be recognised.

Now, what should be happening is that the Dialogue lines would have their right indent set to six inches (at least in my example), but they did not, and so thus they no longer matched the definition. It could very well be this is a limitation in how things get converted. We do the best we can with these conversions, but always stress that the best way to work is to set up your format first before you start writing anything at all, since format based scriptwriting can be fragile if the terms or text is messed with.

Thanks for the answer and the explanation of how things work. Scrivener doesn’t assign the settings to ecach paragraph, like a style sheet. This explains why there was no conversion to the new format. It should be possible to make this work, but I guess it would take a macro of some sort that finds paragraphs with the “old settings” and changes them to “new settings”.

As to “Hollywood standard” I am not aware of any complete definition. In existing movie scripts, such as can be found at, there are big differences in formatting. “Dialogue” in Scrivener has room for something like 35 characters per line, I wanted slightly longer lines, maybe 42 characters. This makes the text easier to read and I don’t see that it violates any rules.

I agree that it’s best to do the settings before writing.


Well normally there would be a conversion. Scrivener looks at the old script definition, identifies items that match it, and then converts their formatting manually to the new settings so that in effect it would be like changing a stylesheet. It’s just that in this case for some reason that doesn’t happen when the right indent is changed. That seems like a bug to me, but it could be down to how elements are currently recognised.

Yes, I agree there isn’t really a standard in the sense that Chicago Style Essay format has rigid guidelines. So it is expected to find a lot of variation out there.

At any rate I found a work-around for the dialogue conversion problem. In my testing if you set the right indend to 4", it will convert correctly, then you can change it to 6" and it will convert correctly. It’s just going from default 5" to 6" that caused problems. Of course you will have to try different numbers for metric, but hopefully that principle of going smaller and then larger works.

Okay, the developer got back with me and this bug will be fixed in the future. It was down to something entirely different than style recognition, so it was a little tricky to find. In the meantime the work-around that I suggested should be good, and once you have it adjusted, it should work flawlessly from that point on. The bug was in the very first modification being made and once modifications are registering the conditions of that bug no longer exist.

Thanks for helping us squash it!

Hooray, I found a bug! Hope it helps with future versions. And thanks for the help.