Chapter Numbering Error in Compile to eBook

I am pretty sure this is a bug, and apologies if it has already been mentioned (I did a search and couldn’t find anything).

I have a document with the following structure:

Manuscript
—Volume One Folder
---------Prologue Folder
---------------Prologue Text
---------Act One Folder
---------------Chapter 1 Folder
---------------------Chapter Scene Text File
---------------------Chapter Scene Text File
---------------------Chapter Scene Text File
---------------Chapter 2 Folder
---------------------Chapter Scene Text File
---------------------Chapter Scene Text File
---------------------Chapter Scene Text File

etc…

Now, to compile, I had no issue compiling to PDF and preview, etc. By only assigning “CHAPTER <$R>” title prefix to the level 3+ folders I had it so the first Chapter folder becomes “Chapter I”.

BUT

With the exact same formatting settings, when I compile to eBook (either ePUB or Mobi) it numbers the first Chapter folder as “Chapter IV”. None of the preceding folders (Vol 1, Prologue and Act 1) feature the “Chapter <$R>” prefix, so I know it’s differentiating them, but it appears it is still counting those folders in the auto numbering, even though they’re at levels 1 and 2, and in theory should be excluded from the level 3+ <$R> count (as they are for the PDF compile).

Am I missing something, or is this a bug?

I am having a similar problem with the chapter numbering. When I compile as an ebook the title page is somehow considered a chapter. It does not place a chapter one heading on the title page but my actual chapter one has a heading of chapter two. When I remove the title page the chapters are displayed properly.
If I compile as a PDF or HTML it correctly labels the chapters with the title page and without.

This is a bug and should be fixed in the current beta, so you could grab that version from the beta testing forum and compile from there to test it out if you like. (Otherwise of course it should be fixed for the next update, which will likely be available in a few weeks–not entirely sure on the timeline right now, since it’s undergoing public beta testing at the moment.)

Hi. I just encountered this same bug on the Windows version of Scrivener. I was publishing drafts in eBook formats for others to read and found the Chapter numbering was off. A folder representing Parts of my story seemed to increment the chapter count when compiled to an ebook format. If I compiled to RTF, DOC or other non-ebook format, it came out fine. It was a relief to discover this is a known bug and is expected to be fixed on the next update.

My question is, what is the status of said update. The reply saying this was being fixed was dated April 21st, almost a month ago from today’s date of May 19.

I love Scrivener, even with a few bugs. Keep up the good work.

Thanks,

Dan

I am having this problem now. It seemed familiar and here I find my own post among those seeing the problem from 2012. Back then I was using Scrivener for Windows. Now I am on a Mac with current version (ver 2.5 for Mac) and see the same thing.

I have Subfolders under the draft folder and chapters in the subfolders. The subfolders are named and I want the names in the compiled version (as if they were parts or sections). I want the chapters to be numbered consecutively on compile. In the Compile formatting section I have tried both <$n> and <$n:chapter>. Both give the same and incorrect result when compiled to ebook (kindle: mobi).

The resulting compiled version increments the number for the subfolder (even though there is no tag in the subfolder) so the numbers end up
“subfolder name1”, 2, 3, 4, "subfolder name2 ", 6, 7. I want the numbering to be
“subfolder name1”, 1, 2, 3, "subfolder name2 ", 4, 5 …

I remember seeing that this was an error and had eventually been fixed in an update back when I had the problem on Windows in 2012. So is the error back? Is there a work-around?

I’ve discovered the problem - or at least most of the problem. Good news - the problem wasn’t caused by Scrivener. The problem was caused by Kindlegen. I updated from version 2.7 to version 2.9 and now the numbering is nearly what I expected. My guess is I need to tweak the formatting in the compile settings to get the numbering exactly as I intended. If you’re having a similar problem, try going to the Amazon kindlegen page (link in Compile settings) and download the most recent version.