Chapter numbers and TOC after update

Previously, I was having difficulty with excluding the the title page and dedication page from the TOC. Post update, I noticed another discussion about placing the text/note for each at the same level as the chapter/folder and did so. Lo and behold, title page and dedication are no longer counted as chapters! :smiley:
But I have now encountered an anomaly in that my first chapter is not being counted (it is being compiled and displayed in my .mobi file). Therefore, chapter 2 becomes chapter 1. I have attached a couple screen captures in order to provide my compile setting and binder structure for this work.
Thanks in advance!
John


folder_and_text_layout.jpg

I’ve set up a test binder structure based on your screenshot, and then set my Formatting settings like so:

Folder 1+ : No Title (Prefix, “Chapter <$n>”)
Group 1+: (ignored)
Text 1: Title + Text (No prefix/suffix—this is for the front matter pages)
Text 2+ (default; no Title just text)

I’m just using .epub to test since that should be identical to mobi in terms of content, and it appears to be working—as does compiling to Preview. So I’d check your Formatting pane and make sure things are set up correctly there.

Way cool! I will give it a test. Thanks!

Okay, if I understood your suggestions, now I get no chapter headings at all in my .mobi. I’ve attached pertinent screen captures. Again, THANKS!
John



Yeah, I think the Title / Title Prefix independance has been lost?

viewtopic.php?f=30&t=19041

Thanks, that was puzzling me, too, because the chapter # precedes “Title” when I try that approach.
John

Well blast, that does seem to be the case. I must have been running beta7 on the other computer or something, because it was definitely working there, but now I’m testing on 1.2 and it does appear that prefix does not work without a title.

Okay, John, you’re lucky because all of your folders are called “Chapter”. :slight_smile: Just turn on Title for folders and add a " <$n>" to the suffix.

Many thanks! Doing that gives me the “Chapter n” but I still have the first chapter issue. (Meaning, the first chapter is unnumbered and the second chapter is displayed as “1”). If I may ask another question, I recall that it was possible to display “One” instead of “1.” I looked but could not find it discussed in the manual.
Thanks!
John
Postscript: Let me add that I am overjoyed to see that now the title and dedication pages are not in the TOC, further complicating chapter numbering.

<$w> is the code that prints a spelled out number.

I’ve attached my test project. If you unzip that, open it up and hit compile it should work. Do the settings look like what you have?
title_numbering.zip (231 KB)

I looked in the manual for a listing of these codes but came up empty. Did I miss it? :confused: Very nice that you just uppercase the code (W vs. w) and you get the text all in uppercase.

Yes. Except I did not have Title on Level 1 checked off.

Now it seems my only issue is the numbering of chapter 1 as 1.
THANKS!
John

The manual hasn’t had these codes in the past because as you can imagine, compiling a project with them not coming out as codes, but still looking the way they should, has been a bit tricky. Fortunately we fixed that issue on the Mac side which should help anyone writing a book about Scrivener anyway. I didn’t have time to finish them for this revision of the manual though. So, that’s why they aren’t documented. For the counters in particular, you can divine the right code to use from the Edit/Insert/Auto-Number sub-menu. Those commands just print the code at the cursor, so you can learn it from there.

So, just to make sure we are on the same page here, the test project compiles with the first chapter folder unnumbered and the second one chapter 2 on your computer?

Understood. Very nice implementation, imho.

Yes, when I open up the compiled .mobi in my Kindle previewer, the first chapter is unnumbered and the second chapter is counted as 1.
Thanks!

Forgot to mention, but we do have the full list of placeholder tags posted here.

And just to simplify the variables as much as possible (since the route to .mobi is long and wild and includes third-party code), what do you see when you compile to Preview instead of .mobi?

Like I say, I get proper output this this file to whatever format I choose—but there might be something odd in your specific .mobi chain; perhaps try updating KindleGen if Preview works fine.

Thanks! I will “preview” and PDF the project on Wednesday and report back.
John

I tested the compile using “Preview” and I still see that the second chapter is numbered as “One” and the first chapter has no number at all. Could something be amiss in my project? I have looked at the characteristics of the first and second chapter re: General Meta-Data and all appears to be identical there.
Thanks for any advice!
John

Well that’s the strange thing, you said you got the same effect in the test project that I sent you as well, right? That project that I sent you works perfectly on my machine. I can compile to Preview, ePub and Mobi and they all start numbering with the first chapter folder as 1. I can’t think of a good reason for why that very same project, when opened and compiled on your computer, would omit the first chapter and compile the second chapter as 1. Is the first chapter set to “As-Is” with the name of the chapter typed into the document, perhaps, rather than being generated by the compiler?

I will be triple-checking the as-is setting and re-do the compile on the test project that you so kindly sent me first thing tomorrow.
thankyou!
John

The test project you sent me does correctly number the chapters when compiled as a .mobi file. However, it prints the “Chapter N” on a page and then displays the first scene in the chapter on the next page. I did not see any “page break before” checked off on the scenes within a chapter (but perhaps I am missing something there).
Does this mean there might be something amiss inside my .scriv file?
thanks!!
John

Okay, I think I found the bug. In your Page Settings compile option pane, disable the “Not on page 1” checkbox in the Page Header/Footer section. This setting has no meaning for e-books anyway, so it is irrelevant to you. For some reason this setting, which should only be impacting page numbering, is also impacting the first auto-number counter as well.

Now I feel incredibly dumb, because I cannot find the “Page Settings compile option pane” while attempting to create a .mobi file. I see it described in Chapter 19 on page 169 but … :blush:

Okay, here is what I did. Changed the “Compile for” to PDF and that displayed the “disable” setting that I think you directed me to. Switched back to compile for .mobi and chapter one now displays properly but I am getting a page break before the actual text appears (meaning CHAPTER ONE prints on its own page).
Still, I’m making some progress here (I think)! :slight_smile:
John