Chapter numbers repeat when compiled?

I’m compiling for the first time and I’m trying to make an outline where the first chapter is #1, the second is #2 and so forth. I’ve set it nested docs/cards = chapters, and the default for a doc is ‘section.’

What’s happening is the chapter numbers reset after every chapter that has section docs. Like this:

  1. (chapter w/ no nested docs)
  2. (chapter w/ nested docs)
    A. nested doc
    B. nested doc
  3. (next chapter)

After every chapter with nested docs, it resets. It has something to do with nested docs but I can’t figure it out (and googling has failed so far).

What file format are you compiling to? And are you using one of the outline compile formats (e.g. Enumerated Outline, Outline Document, etc.)?

I’m using a customized version of the Indented Outline (I enabled all the metadata, plus the notes). I guess it’s not clear to me how the sequential numbers work for the top level items.

I can’t think off the top of my head what might cause the numbering to reset itself. I’m assuming you’re using alphanumeric numbering? What section layouts do you have set for your groups/folders and your text documents? What file format are you compiling to (Print, PDF, DOCX, etc.)?

A screenshot of how you’ve got your Binder organized might be helpful. If you’ve got private information in there that you’d rather not share here, you can recreate your Binder organization in a new project using different document titles (I’m only interested in how you’ve got it organized hierarchically) or you can contact support and reference this thread.

If chapters with and without nested documents are the same section type, that shouldn’t happen. If it does happen, that means that somewhere (likely in the section layout for nested document chapters) you have a placeholder something like <$rst_chapter> or <$rst_n>, the former if the chapter number stream is named “chapter”, the latter if the chapter numbers are <$n>. (Similar if the stream has another name or chapter numbers are <$t>, <$w>, etc.

Perhaps this will be helpful: https://vimeo.com/594898941/42e19a44f4

I’m working in the Corkboard & Outliner & stacking cards to create ‘Chapters.’ The default section type for a file is ‘section.’ The last chapter I highlight before opening the Compile settings is the first chapter where the numbers reset. I noticed that the previous chapters & sections are set so theoretically it shouldn’t happen.

I didn’t edit any placeholders (that I’m aware of), I mainly checked all the boxes. Of course since I’m not that familiar with all the settings maybe that caused the issue?

The video link does not seem to point anywhere for me.

One way in which this might happen is if you assign Layouts that are intended to be used in the opposite order you are using. So to use for example one of the “Paperback” built-in Formats, if you were to assign what is being used for chapters to “Numbers Section”, and what is used for sections to “Title Section”, then you would never get past “1” for the chapter numbering. That’s because the former is designed for numbered sections, and gets reset every time you use a title section.

You can confirm whether that is happening by double-clicking on the “Section” preview tile in the compile overview screen, to edit the Section Layout in the format design window. In the Title Options tab, do you see something like <$rst_scene> in the prefix or suffix field? If so, just remove it; if that’s how you are using the layout you don’t need it.

Sorry - I pasted the wrong link. This is the right one: https://vimeo.com/594898941/42e19a44f4

I’m using a customized version of Indented Outline and I didn’t edit the format - I just checked off the various boxes to add metadata, etc in the Section Layout window.

How is it customized if you didn’t edit it?

Thanks, that link worked! All right, with the precise ingredients of what you are doing conveyed, I think the main problem is that you’re mixing two different kinds of outlines together into the same indented list, which produces the visual effect of it being one list, but in fact each list is interfering with the other because they are considered new lists when you switch types.

I’d either standardise on one type of outline list for the entire outline, or look into creating your own by hand, using the different auto-number tokens. For example change <$hn> to <$n>, since for how you’re using it that is all you get anyway: 1, 2, 3., and then use <$L> for uppercase alphabetical numbering on level two, etc. You can use <$n><$rst_L> in the chapter level prefix, to have the alphabetical counting reset.

How is it customized if you didn’t edit it?

Ha, you got me in a semantic bind. I edited some settings (checkboxes) but didn’t touch any formatting.

1 Like

I’m confused as to how I’m mixing two different kinds of outlines. When I choose the preset ‘Full Indented Outline’ in the Compile window, the export does the same thing with the renumbering.

Maybe I have a different idea of what an outline should be vs what Scrivener outputs?

I’m using the term somewhat more technically, perhaps? There is an outline in the sense of the thing we use to communicate structured ideas with one another, using common conventions for doing so (indenting, markings of some sort to indicate new entries). Then there is the outline as a technological construct that is working to create the outline we as humans recognise. I.e. it’s the thing that numbers lines for you, and keeps them numbered sequentially when you move them around, or indents text without you having to bang the spacebar over and over—and in Scrivener’s case, the system that is turning one outline (the binder’s headings and optionally synopses) into another (a formatted rich text file).

It’s the technical outlining generator that you have two of, woven around one another from one indent level to the next and creating the human illusion of a single outline.

One produces 1, 1.1, 1.2.2, 2.1 style outlines. The other produces I, A, 1, a, i, style outlines.

OK. I’m still unclear why when I choose the preset ‘Full Indented Outline’ in the Compile window, the export does the same thing with the renumbering.

Sorry, I don’t quite understand the question. I thought that is the Format we were talking about (or a lightly modified version of it at any rate)? The auto-number placeholders I described come from that setup.

The autonumbering is not working - that was the main reason for this post. The only modifications I made to the format are checking some boxes to include metadata (shown in my video) and the default preset for the format has the same numbering problem. I’d like to figure out why and fix this issue.

I understood the original question. Have you attempt either of the fixes that I described in the second paragraph of this post yet? From what I can tell, all you have tried so far is switching from your custom version of Full Indented Outline to the built-in version. Both use the same exact counter settings, so you would observe no difference between them, beyond your customisations to content.

I did not, I don’t know where to make those edits.

The easiest one to try would be to select only one type of outline numbering for your draft. Instead of assigning the Decimal Outline Item layout to one level and the Alphanumeric Outline Item layout to another, choose one of those for all of the section types in your draft. This change would be made in the same place you made those assignments initially, from the main compile overview area, clicking the Assign Section Layouts... button.

The other method I described was leaving the assignments you have alone, but then editing your custom Format to change the auto-number placeholders to regular counters instead of the special outlining counters—to make your own outline format. They are found in the Section Layouts pane, where you added Notes and Synopses, under the Title Options tab.

I found where to do that and made sure only ‘Decimal Outline Item’ was check for title and that fixed it - thanks for your help (and for putting up with my stupidity)!