Chapter titles not appearing in compile

Hi! I’m having problems getting my chapter titles to appear when I compile. My project is structured really simply - each chapter is a complete text document, and the document name is the chapter name. They are arranged one after the other, with no folders.
I am compiling into epub, using Novel Standard Manuscript Format as my start-off point for formatting. I am including all of my chapters ‘as-is’, and inserting a page break separator between each text document. On the formatting tab I am including text and title. I have formatted the text and title to what I want them to be, and removed ‘Chapter (number whatever)’ from the section layout, as I don’t want the chapters to have be numbered at all - I just want them to be headed with the name of the chapter as taken from the name of the document.
The ToC is fine - it has the chapter names in exactly as I want them. But each individual chapter just starts straight off with the text directly after the page break - no hint of a chapter name at all.
I’m fully up to date with version 1.5.7.
I’m feeling really stupid, because I know I’ve done it before, I just can’t remember how! Any help will be hugely gratefully received.
Thank you!

Setting a document to compile “as-is” causes only the document text to compile; this is overriding your setting to include the title element as well. Deselect “as-is” on all those documents and you should be fine. Typically you really only need to use “as-is” sparingly, for documents that of course only need the text and that should not have their editor formatting overridden during compile, when other documents will have the formatting overridden. If you don’t want to override the formatting for any of the documents, just deselect “override text and notes formatting” in the Formatting tab of Compile. That will leave the text of your documents just like you see it in the editor, but it still allows you to include other elements, or exclude the text (“as-is” documents always compile the text, even if text wouldn’t normally be included for that document type and level, e.g. if you had selected only the title to compile, an “as-is” doc would still compile the text, and not the title), and to format any elements other than the text and document notes (so you can add a title and format it without touching the formatting of the document text).

Thank you! I knew it was going to be something that was staring me in the face, I just couldn’t think what. You are a star and a lifesaver.

Hi. My issue is that my text titles don’t appear in the compile. I have deselected ‘As Is’ already and that didn’t fix it. The Override text and notes formatting is unchecked.

Folders will print their title but not the text files. I’m trying to compile an rtf doc to use for editing but want both folder and text files to have a title. I feel like I’ve tried everything.

Any suggestions?

In the Formatting compile option pane you’ll find a grid of checkboxes in the top half. This is what controls whether or not items export text, titles or other extra information. The other axis in this grid is the icon type. You’ll see a folder icon at the top, and minimally two other icons, one for stacked files (or files that contain subdocuments as though they were folders) and lastly for files—though some templates and presets come with additional rows out of the box (so that folders at one level do something, like print “Part 1” while folders at the second level and greater print “Chapter One”). So make sure to scan down the list until you find the file icon type, and then across the row to check the “Title” checkbox. If your settings have more than one file depth type, you’ll need to set that for each one.

Thanks AmberV. If I read your post correctly I believe I’ve done that. I even tried adding 5 deep text files and checked title on all of them to see if my text pages were too deep.

Here’s an interesting development - If the text file has a text file underneath it the title prints.

In other words, if this is the binder and Title is checked in Compile for all folder levels and all text levels, here’s what happens:

Folder: (title prints in compile)
…Text: (title prints in compile)
…Text: (title does not print)
…Text: (title does not print because there’s not another level below this)

Any ideas?

To clarify one thing, you usually only need one level setting per type because these will implicitly apply to all levels “below”. This is the purpose of the “+” signifier on the end of the deepest entry. So if there is only one level defined, it will say “Level 1+” and that means what you set up there will apply equally to a text file at the very top of the list in the Draft, or some deeply buried file at outline level 10. The need for adding additional level controls is only necessary when one level must act differently than another—as with the aforementioned Part/Chapter example.

As for why a text file with another file in it prints a title, that does make sense because this is considered to be a separate “icon” for purposes of Formatting. The icons that look like a stack of paper relate to any files that contain files. This way you can have two different types of formatting be done at the same level, by using folders for some things and file groups for others. It just provides a little additional flexibility.

The first thing I would try is to pare thing down to the basics, as much as you can. Discard the five level depth controls and try working with just one text icon labelled “Level 1+”. Click the “Title” checkbox for that, and then examine the mock editor below it. You should see a title line available for formatting (regardless of whether override formatting is ticked).

Another thing you can try, if you have not invested a lot of time in setting up your compile settings, is to switch to another preset in the “Format As” drop-down. I would recommend Enumerated Outline, as its purpose is entirely to print the titles of the Binder and nothing else, in an indented and numbered list. If that doesn’t print the titles for the text sections it could indicate some kind of bug or unforeseen issue in the Binder itself. If it does work, then we know that in theory things should be solvable in the compiler; we just need to find the right combination of settings.

Thank you again Amber V! Success!

  1. I did pare down the compile to Folder Level 1+ and Text Level 1+. When I clicked onto the Text Level 1+ the preview window showed this:

Text: TITLE (I changed formatting to all caps)
Beneath that is the greeked text as it should be. But the titles didn’t print.

  1. Then, I tried the enumerated outline, as you suggested and it did print the titles.

  2. Then I checked the text box in the enumerated outline and it printed both the title and the text for all files.

  3. So I went back to the custom setting that I was working with earlier, made sure all titles were checked again and hit compile. Eureka, this time it printed all titles and text for folders, multiple text files and single text files.

BUT it kept the outline number in front of the title and the formatting of the title disappeared. I played with it, set it up again how I wanted it, got the outline numbers to disappear and formatted the titles, then I saved the Preset and I’m set. Thank you for your help!