Character Image in Scrivener 3

I recently upgraded to Scivener 3 and so far I love it. However, I’m having a problem.

I’m trying to add a character images to my character sketches. However, when I go to the Insert tab ‘Image From File’ is greyed out. The only way I can seem to import a picture is by putting it directly into the file, displacing text. Not only do I not want the picture there, but it also doesn’t seem to give me the option of dragging and dropping it into the Inspector.

Help?

I believe that’s the menu option for inserting images inside a document.

I think what you want to do is 1) Select a binder item, 2) do File > Import > File, then 3) browse to and select the image. This is explained in the Interactive Tutorial (Help > Interactive Tutorial), in the section named Importing Files.

In the Inspector, in the right side of the Synopsis area, there’s a small button that toggles the Synopsis from text to image. Set it to image, and then you should be able to drag and drop your character images into the Synopsis.

image

Let me know if you have any further questions.

Best,
Jim

2 Likes

You shouldn’t get that error message unless your character sketch is inside the Draft/Manuscript folder, where Scrivener does not allow image files. It allows images inside manuscript files, but that’s a different thing. Ordinarily, character sketches are in Research (or elsewhere outside the manuscript).

My understanding is that the OP was trying to add an image as a binder item, so my guess is they had selected and had focus on a binder item. In that case, the Insert > Image from file menu option will be grayed out, because it’s meant to place images inside a document, so it expects the focus to be inside a document.

At least that’s what I think happened, because I experienced the same thing when trying to recreate their issue.

Best,
Jim

1 Like

Yay! Thanks. All is good now.

Yes, that’s another explanation, maybe a better one.

1 Like

Then again, why does Insert Image from File display when a binder item is selected, only to be greyed out? I think it’s because a user may want to insert an image in the binder, which can’t be done in the manuscript.

[quote=“drmajorbob, post:7, topic:123353”]
I think it’s because a user may want to insert an image in the binder, which can’t be done in the manuscript.
[/quote]

Yes I think we’re agreeing. 🥸 If the user has a only binder item in focus, the option will be greyed out. If the focus is in the editor inside a manuscript document, the option will also be greyed out. For the option to be available, the focus must be in the editor inside a non-manuscript document.

ETA: Clarifying post downthread.

I just tested this on the “Splitting the Editor” document in the Mac tutorial project. With the focus in the binder (click on the document title in the binder), when the document is in the Drafts folder, Insert->Image from File is grey. But if I click into the text of the same document, the menu to insert an image (Insert->Image from file) is available and functions as expected.

Yeah, so this is what happens when a well-intentioned individual (me) posts about a feature they believe they understand but seldom use (images in Scriv).

I confused the Draft/Manuscript folder restrictions regarding images, thinking that the restrictions applied to images in text as well as binder items. Thank you for pointing out my error.

While we cannot add images as binder items (File > Import > File) into the Draft/Manuscript folder, we can add images inside any text in any folder using Insert > Image from file.

Time for my coffee.

Best,
Jim

Insert image is two entirely different functions, one when a document is selected vs. another when the cursor is in a document. I never expected them to have the same restrictions.