check spelling while typing not working

Hi,

I have check spelling while typing selected, but it does nothing. I have placed intentionally misspelled words in my document and there is no underline or any other indication that they have been spelled incorrectly. Is this a bug? How can I solve it? I’m using Scrivener on a 2.66 GHz Intel Core MacBook Pro with os 10.7.3.

Thanks.

Have you updated to Scrivener 2.3? Lion introduced some bugginess with the spell check which should be fixed with the latest Scriv update.

Also note that there are two settings for this: in the Corrections pane of Preferences, you can enable or disable check spelling as a default setting for new projects, but it can be turned off or on for any individual project via Edit > Spelling and Grammar > Check Spelling While Typing. So double check that second one to make sure you’ve not just accidentally turned it off for your current project (⌘\ is the shortcut, so you may have hit it inadvertently at some point).