Chinese text in pdfs not showing up

Hi fellow users of Scrivener and the CHinese language!

I wonder if any of you have had problems importing Chinese pdfs into scrivener?

I have some pdfs from statistical yearbooks that I want to import into the research files on scrivener, but after I drag and drop them they show up empty – bar some gobbldey gook in the footer section of each page. The title is showing up in the title bar in Chinese no problems.

Seems odd that a pdf would do this. I’ve got other pdfs with CHinese included that show up fine, seems just these yearbook ones that are problematic!


Hi Kelly,

Not a problem that has affected me, and as a Mac user, my experience probably wouldn’t help. But just wondering where the ones that aren’t showing came from. It sounds to me that perhaps the ones that are showing are graphical PDFs, i.e. images, and the ones that aren’t are textual. You can check by opening the PDFs in Reader or equivalent and try selecting a short stretch of characters. If you can’t, if you can only select the whole thing, it’s a graphic.

So, if I’m right, your work-around would be to convert the textual ones to graphics, though I don’t know what you’d use to do that on Windows. Of course, the problem with no-show for the textual ones is another headache for Lee and I’d guess it’s related to the “import Chinese” problem.



Actually this is probably a separate issue from the import problem, since that has to do with the RTF encoding and PDF import has nothing to do with that; this is more likely an issue with the tool being used to display PDFs in Scrivener. If you could send an example PDF that’s not importing properly to support AT literatureandlatte DOT com, I’ll pass that on to Lee so he can test this; it’s going to be a post-1.0 fix (especially if it’s something that he’ll need to check with a third-party about) but having a sample will help a lot toward nailing the problem and correcting it.

Yeah, I admit I’m not really a geek and don’t know the underlying mechanisms, but I’d still put my money on the ones that are showing being the result of scanning, and the ones that aren’t showing being the result of print-to-pdf or equivalent.



Oh yeah, that’s quite probable. I didn’t comment on that because I didn’t have any suggestions for software to convert it, but I’m sure there are plenty options that Google will reveal. :slight_smile:

Hi guys

it is text pdf. I can’t seem to work out how to turn that off, perhaps except to save it as a jpg? Kind of a pain since it adds an extra step to a painless drag and drop.

I’ve sent one of the files through to support.

Thanks, I’ll get that on to Lee so hopefully we’ll be able to get a fix for this before too long. Sorry about the trouble!