CJK input?

Hi,

I downloaded the latest beta version (1.5.3.1), and I first tried something I call “basic”, even if it is maybe not for everybody: I tried using a different input method. Japanese.

Nothing:

  • Shortcut to switch to different input method does not work
  • If I manage to swich input method in another window, and if I come back to Scrivener later on, only western characters appear as I type (for instance, if I type “ga”, I get “ga” instead of “が” with a dropdown menu proposing the different ways of writing “ga”).

I have 2 questions about the issue:

  1. Did I miss something, or does it simply do not work?
  2. If it does not work on Linux, does it on Mac/Windows? Are there any plans to support CJK?

Thanks,

Bruno.

Can’t say for Windows for Japanese, but kdombros used it for Chinese — though I see her last post was July last year; on the Mac it works well for Chinese —I have used it myself while Scriv for Mac was still in beta — and I imagine for Japanese. I seem to remember reading something about glitches with Korean on one of the platforms.

Mark

EDIT: apart from the correction in the first line, if you search for Korean in the forum search, you’ll come up with any posts that refer to it.

I thought there were a few Korean users, as well? They posted in the Bug forum, if memory serves.

To Xiamenese and Garpu: I did not find anything specific about Linux. Some posts in other flavours (Mac mainly), many of them being about display (not input method). It appears that CJK input seems fine on Mac, however…

Yes, I think you’re the only one who has started a thread on CJK in Linux. So I don’t know where you’re going to get help from. Although the OS-X is Unix under the hood, it’s going to be so different that I won’t be able to help you. And in my experience, the CJK input on the Mac has actually been pretty solid since Mac-OS 8, when I first started using Macs seriously in the early 1990s. Let’s hope someone else on the Linux forum uses such languages and will chip in for you.

Cheers
Mark

I investigated this only briefly, when I was thinking about learning Korean, but I believe you have to have both the font installed and the means to handle it. Last I looked–and it was awhile ago–SCIM was recommended. I think you need to use both SCIM and the keyboard layout provided by your window manager.

But with the caveat that I didn’t get much beyond learning what sound goes with what letter of the alphabet. :slight_smile:

In fact, I use iBus framework for input (iBus seems to replace SCIM framework for some time now). My keyboard layout is correctly configured, and the both Japanese (Anthy engine) and Chinese (Pinyin engine) input work perfectly everywhere on my desktop.

Hi all,

I found a (the?) solution: Starting the iBus framework with the --xim option. This enables input methods to work with some rare applications.
Feel free to contact me if you have similar issues.

ありがとう!

ボヂチェア

Cool, good to know!

Yeah, it was awhile ago that I was investigating such things.