Clickable Links Problem

Scrapple Version 1.0 (3996) - Mac OS X 10.8.3
I’m able to create a note with a clickable link. It is displayed as a link. Nothing happens when I click it.

Thanks …John

It’s necessary to be in editing mode for the note in order to click the link, so if you double-click the note first, are you then able to activate the link?

Yes, your suggestion worked.
Thanks …John

Hello everyone - my first post!

Loving Scapple - very pleased I took the plunge, as it is proving very useful in the context of my dissertation…

Most of the questions I had, have been answered - after spending a few hours reading through the various forums - but I’m still stumped on the “link(ing)” of files…

I gather I can use Cmd+L to ‘link’ other Scapple ‘pages/projects’ to a “main/upper-level” Scapple page - which will see Scapple almost working in a similar manner to the Cmaps software, with everything being live-linked to each other, at different levels?

I furthermore gather that it need not only be a Scapple page that gets linked, but that I can use this to open PDF’s (and even applications) that are stored on my Mac? Is this correct?

That aside, I’m not having much luck at the moment. And even trying what is suggested above, is not working.

Here’s what I’m doing currently:

I 2xclick to open a new note.
I either change the words from the default [New Note], or I simply hit Cmd+L immediately.
The dialogue box opens, I then drag the filename of the Scapple project/page or PDF into the dialogue box.
The words [New Note] turn blue, and are underlined - indicating a “live-link”.
I ‘exit’ the note (click elsewhere on the screen).

When I 2xclick the note again - the dotted border extends, and the flashing cursor is “in” the text [New Note].
Dragging my pointer over the [New Note], it turns to a little white glove/hand.
If I leave it stationary, the complete link-address pops up, in a small, yellow floating window.

When I 2xclick the link, with the white glove pointer, I get the standard Mac beep, and nothing else.
Right clicking it, allows me to edit the link - but “open link” also does nothing?

What am I missing?

Apologies for the overly-detailed post. I fully expect a pithy 1-line comeback explaining what I’m doing wrong - to be followed shortly thereafter by a monumental facepalm this side! :laughing:

Thanks in advance!

It can be a bit finicky at first: you need to make sure that the address of the file you are linking to is in the correct format. That doesn’t always happen automatically with a dragged in link.



Ah - thanks for the pointer…

I’ve tried it again, included “file:/” in front, since when dragging in, it already placed “/Users/owner/Documents/Active/ACADEMICS (Active)/Thesis…pdf” - but no luck! :neutral_face:

No doubt a ‘directory tree’ issue then - something must not be leading Scapple to the file in question - will play around with some files on the desktop, and see what I can manage.

Different strokes …

Should be - file:///Users/…

The drag will include one /
So you need to add two more.



Eric - you just saved me hours! Would never have figured to still add the extra forward slash! :blush:

That did the trick - works perfectly. Thanks a bunch!