Clicking in a New Document

This is an odd thing - I’m not sure it’s a bug. Perhaps an undocumented feature?

If I create a new, blank document (in normal view, with no split screen) and then click in the bottom half of the doucment window, the cursor doesn’t appear at the top of the document. I have to click approximately half-way up the screen before the cursor will appear. I know … most people probably click where they mean to start typing, but I’m lazy and just aim for the ballpark. Perhaps a little more precision is called for on my part?



Margaret, I cannot recreate your bug. Maria, I am guessing that you have typewriter scrolling switched on, in which case things will work differently. I cannot find a bug in this area at all.


Yes, remember that typewriter scrolling does create an extra white part of the view after the end of the text - without this, typewriter scrolling wouldn’t work when you were typing new text, which is one of the best things about it…
All the best,

Keith, I don’t think this is worth the bother, so please don’t spend time trying to figure it out. If it were a large issue, other people would be reporting it, so I’m sure it isn’t. On the other hand, the problem kept bugging me, so I thought I’d let you know what I found out after doing some experimenting.

At first, I thought the difficulty might be related to typewriter scrolling, but I had odd results whether I had scrolling on or not.

The problem is not having the cursor show up when I click at the bottom of the screen in a new/empty document. It seems to be related to the length of the file I was in before I created the new file. If the previous document was not quite a page long, there was no problem in the new file - I could click anywhere in it and the cursor would show up. If the previous file was a full page or longer, then I couldn’t click at the bottom of the new file and have the cursor appear.

There was one exception. If I had typewriter mode turned on and my cursor was at the end of the long file, I could leave the cursor there and close out of the program. When I restarted the program, my cursor would be in the long file, in the middle of the screen. I could click in the file, then go to the new file and click anywhere without a problem. If I went back to the long file and clicked in it again, the text was still at mid-screen, as was my cursor. I then tried going back to the new file and found I could no longer click at the bottom of it and have the cursor appear.

And just to make life really difficult, sometimes I have similar results when I click at the bottom of a short file that does have text (say 9 lines).

AWK! Don’t let me drive you crazy - one of us is enough. I’m ready to call it quits and resolve to click at the top of the screen in the future!


Oh, wait! I think I know what this is - and it’s not a bug, either. When you say that you are clicking at the bottom of the document, you mean right at the bottom, right? Well, remember that the document has margins - you set them in the Text Editing tab of Preferences, and they are set to 20 pixels by default. These margins go around the sides of the document, and they are also right at the top and right at the bottom of the document. These margins are inactive - clicking in them will do nothing. So, if you click in the 20 pixels right at the bottom of the document, indeed, nothing will happen!

Hopefully that is what is happening here. This is just how the margins are - you can always make the margins smaller if you want via Preferences; you can get rid of the margins at the top and bottom altogether, for instance, which should make your problem go away.

All the best,

Well, not really. I had the margins set to 0 (but I did try this with them at 20), and I was clicking somewhere in the lower third of the screen. I’ve been feeling bad all day for going on about this. Chalk it up to my obsessive nature. What drove me crazy was wanting to figure out what was happening, not the program itself. I love it.

I have resolved to reform and quit being so dogged. Of course, I have done that before - most doggedly.

Have a good weekend and spend a little time with your family!


Strange, because I cannot recreate this at all. And I have tried.

Wait… You don’t have your scale turned to something less than 100%, do you? Anything under 100% and there would be some inactive parts of the view in files with little text. In 75% scaling, the bottom quarter would be inactive, for instance… The same could happen if you went to 100% after being at a different scale. Scaling can had odd effects like this - text views don’t really have an easy way to scale, unfortunately, and you will see strange things like this in any program that allows you to scale (including DevonThink and Avenir). Let me know if it might be to do with scaling…

I have been using 125%. [For the clear version of things, skip the text just below this and pick up after the asterisks.]

This is totally flaky. I tried and tried to duplicate the problem tonight with typewriter scrolling off and on (I am closing and restarting the program between mode changes) and I could not get things to go wrong. (Exception noted below). I switched to 100% and couldn’t make the problem happen. I switched back to 125% and suddenly I had it again. Once it started up, I could get the same result over and over with scrolling off or on.

The exception I mentioned above is what was happening if I was coming from a document in which the scroll bar was at the bottom of the window. If I clicked in the new/empty document, the scroll bar in it would be at the bottom of the window and the cursor would be hidden at the top. This is the same problem Maria described above. But if the scroll bar had been at the top of the window, that’s where it would be in the new document.

This is getting confusing, so let me regroup and summarize what’s happening.

At 100% view, with typewriter scrolling off or on, everything is working and I don’t see a scrollbar in the window of a new/blank document.

At 125%, with typewriter scrolling on, I had pretty much the same problem I first reported - if I was coming from a document with text that extended more than one screen, I couldn’t click in the bottom of a new/blank document and have the cursor show. There were no scroll bars in the new document.

At 125% with scrolling off, the new/blank document has a scrollbar and the bar is in the same position as the last document I was last in. (If this previous document was a longer one and I was partway into it, the scrollbar showed at the bottom of the blank document’s screen.) When I click in the window of the new/blank document, the cursor is at the top of the document and not in view - I have to go up a screen to see it.

It has to be the 125% zoom level that’s throwing things off. Two different things are happening at that zoom level, depending on whether typewriter scrolling is off or on.

If you can’t duplicate the problem at 125%, I’m beginning to think something has gone wrong with the program or my preferences file. Would it help to trash the preferences file and see what happens, or even trash both the preferences and the program and reinstall Scrivener from scratch?

These things happen in a second project I have, so that should rule out anything being wrong with the projects.


Hmm… Strange…

Well, for a start remember that the scroll bar may be visible even in blank documents when the view is scaled to something bigger than 100%, because not only the text gets scaled but the whole of the view. This is just an issue with text views in general - you will see the same behaviour in DevonThink and Avenir.

With typewriter scrolling on, there may well be inactive parts of your view at the bottom.

I can duplicate this problem, especially with typewriter scrolling on, but to be honest attempting to fix it is a very low priority. The problem is that scaling in text views is flaky in general. It’s the sort of thing I could spend weeks on with no joy. So, like I say, I will take a look at seeing if there is an easy fix, but this may just be a quirk you have to live with for the foreseeable future.


Okay, I spoke too soon. :slight_smile: I think I have tracked this one down. I have sent you an early version of beta 4 for you to test out. Let me know if it resolves these issues for you.

This fixed the problem.

Thanks so much forall your help!