clippings from Services menu?

I’ve tried using Services menu item:
Scrivener: Append to Current Text & Scrivener: Make New Clipping
but both of them launched Scrivener 1.54
After deleting the old version they didn’t work.
Are they available for Scrivener NaNo 2010 ?
If so, how do I activate them?

They should be working—but you might need to log out and back in to get them registered.

Not working for me. rebooted. still nothing. When I try to make a clipping from Safari I get an error message saying the service could not be used because the “scrivener” application could not be found. Could this be caused by something left over from my old version 1.54?

That’s definitely what it sounds like. Try visiting the Keyboard section of your system preferences, and see what Services are available in the Text section. There should be about half a dozen of them available.

Thanks Ioa, suddenly the Keyboard system prefs window was littered with Scrivener services!
There’s a bit of a problem with Apple’s dumb limit on name length in the prefs. See attached screen cap.
I worked out which ones were the version 2.0 services by trial & error. The addition of choice of formatted or unformatted is a great idea. :slight_smile:
How do I get rid of the old services from the sys prefs? Where do Services live? I looked in Library > Services but couldn’t find them. Any ideas?
Screen shot Scrivener services.png

Services cannot be independently deleted, only disabled via this interface here. They actually exist inside the application bundle itself and nowhere else—so the only way to delete them is to delete the application. The Library/Services directory is for programs that are services and nothing else. I have a few like that—a few that I’ve written for myself. They just process text and spit it back out, so they don’t need to interface with a host program.

Actually I had this one - I tried renaming the 2.0 beta application file, ie “NaNoMac” or whatever it is as “Scrivener” in Applications. That worked.


I believe I am having a related problem: I have now removed the old version, installed 2.0, after many restarts the old services are gone and the new services are showing up.

However, when attempting to deploy any of the new services, everything works (the file naming window shows up) except the clipping is never actually made, or it is not showing in the active project and disappearing somewhere that I cannot find. Ideas?

Yes I think I have the same problem actually


Huh, same here. I make sure I only have one project window open, opened to a blank text document, type some text into TextEdit, select it, and choose the “Append to current text” service. I type in “Test” and hit Enter… nothing happens.

Anyone else having success with clippings?

Oops… Er, yeah, that was a fix for a bug I did yesterday… Which instead stopped it working altogether. I’ll have this fixed tomorrow, sorry about that.

Hi Keith,

Is the disappearing clippings problem now sorted? If so, what do I need to do to get it to work? Download 2.0 again and re-install it?

Many thanks,

It is fixed for 2.0.1, but not in the present build. 2.0.1 will be out soon, hopefully within the next week.

I have the same problem. Anyone got any ideas? :frowning:

Fix coming soon, with 2.01, I believe. :slight_smile: