Closing Comment Makes Text Blue and Underlined


Sorry if this is a silly question; I’m new to Scrivener.

I’m working in a project, in revision mode, and I have some comments in my documents. I go through, editing the text, and maybe make some changes to the text that the comment is on. When I close it and then add/delete surrounding text, the text color turns blue and it becomes underlined.

I tried to cut and paste the text, but that didn’t work. Some other things that I tried also didn’t work.

Any help will be greatly appreciated. Thank you!

Highlighting the text that “anchors” a comment is the expected behavior. Is that what you’re seeing, or something else?

If you haven’t already, I’d recommend taking a look at our Interactive Tutorial, available from the Help menu. It’s a good overview of fundamental operations like this.


Thanks for the response.

What is happening is that I have a piece of text with a comment anchored to it, and then when I close the comment, it highlights the text as if I clicked on one part of the text and dragged the cursor to another. When I click and type immediately after the comment, the text (no longer highlighted in any form) will turn blue and have an underline as if to show that’s where the comment was. Sometimes it’ll extend to the nearby text.

Not sure if this is intended or not.

Thanks for your help.

Could you post a video?

I’m not sure what you mean by “closing the comment.”

As long as the comment exists, it’s going to be anchored somewhere. It sounds like you’ve made the anchor point small enough to be invisible, but since the cursor is inside the anchor, any text that you type will be part of the anchor, too.

To see this behavior manifest in a less mysterious way, select two or three words and link a comment to them. Then put the cursor between words and start typing.


Sorry that my explanation is confusing.

Here is a screenshot of this:

By closing the comment I mean either deleting it or pressing the “X” in the upper right corner.

Thanks again for your help.

Huh. Very odd. And thank you for the video, it definitely clarifies things.

I’m going to say this is probably a bug. What version of Scrivener do you have, and with which version of Mac OS?


I am on Scrivener 3.1.5 and MacOS 10.15.3 (Catalina, not the latest version).

Thanks for your help and effort, it’s really appreciated.

Does the problem still occur if you upgrade to the latest version of Catalina?

Scrivener depends on the Mac OS text system, so to confirm this as a bug we need to make sure you have the latest versions of both it and Scrivener.


Ok, so I upgraded to the latest version of MacOs (10.15.6) and tried to replicate the issue.

The process shown above doesn’t seem to cause the error anymore, but if I add some more text and delete it, the words will turn blue and be underlined as before.

Thanks for your help.

Please create another video and a small test project demonstrating the problem, and send both to our support address,

Include my name in the subject line, and add a link to this forum thread.



Ok, I sent the information to the address you gave.

Thanks for all your help, it is really appreciated!