Closing double quote backward after emdash

When adding a closing double quote after an emdash it adds an opening double quote instead.
[attachment=0]double-quote-emdash-issue.PNG[/attachment]

Smart quotes aren’t. Even Word gets this wrong. Best bet is to type in the sentence fragment with the quotes (so you can see that they are right), then add the emdash in.

So not true. MS Word gets it right, and so does Scrivener 1!

On Word in the M365 subscription, I get a straight quote after the emdash.

That seems sub-optimal.

[attachment=0]WordQuoteAfterEmdash.jpg[/attachment]

This is Word 2016 on Windows - fully up to date:
[attachment=2]Screenshot 2021-03-26 180748.png[/attachment]
This is O365 online (note that it doesn’t get doing double dashes to get an em dash):
[attachment=1]Screenshot 2021-03-26 181559.png[/attachment]
This is from Scrivener 1.9.16.0:
[attachment=0]Screenshot 2021-03-26 182156.png[/attachment]

Obviously it won’t work if there’s a space before the double quotes, but it should otherwise.

Sad but true. I’ve been working around this issue forever.

I automatically add a letter after the closing em dash to obtain the correct quote.

I’ve had to train myself to not use spaces on either side of the emdash. Unless you’re writing using the AP-Style Guide, then the spaces are superfluous. Fonts should kern correctly and leave a tiny amount of room between the letter, the emdash, and the next letter.
I’m old enough to have actually worked in old fashioned print shops and “electronic typesetters”. It’s been a tough transition. Much like training myself not to use double-spaces after periods (full-stops) and colons.

I’ll second the ‘I use Microsoft Word 365 subscription and it gets smart quotes after em-dashes right all the time’ club. I saw another thread somewhere on this forum that claimed Word doesn’t do this either, and honestly, my jaw dropped. Word absolutely does do this. It is, however, an option you must tell it to do. Specifically, one must go to File>Options>Proofing. Then click on AutoCorrect options, select the tab ‘AutoFormat As You Type’ and check off ‘replace straight quotes with smart quotes.’ So I guess there’s just a lot of people out there who haven’t.

And I’d be pleased as punch if the same thing was an option for Scrivener. If people don’t want it to behave that way, fine, but please give me the option to customize this behavior.

I would really, REALLY like to have this fixed. I’ve seen all the workarounds, I hate them, and there’s really no reason that this can’t be done right. Hell, I’d settle for being able to use ‘Edit Substitutions’ under Corrections, but that holds the information as plain type – thus no subbing a left to a right quotation mark will work (believe me, I have tried). I use this often enough that it really irks, particularly when my documents are typically 200k or greater.

I use emdashes in dialogue all the time, where the emdash is followed by a closing double quote, no space between them. Scrivener 1 got this right every time.

Scrivener 3 gets it wrong every time and it’s maddening.

Please fix this problem!

1 Like

Came here expecting an actual fix. Thought there’d be some way in the options to correct this. Even Reedsy gets this right and that’s a free online app. In which situation would an opening quote after an em-dash make more sense as the default setting when it happens most commonly at the end of interrupted dialogue?

groans Spent hours trying to find this in the settings somewhere. thought I was doing something wrong.

1 Like