Cmd-Option-1 impossible to assing, even after deleting Centered Text style

I can assing every Cmd-Option-number shortcut to my styles except Cmd-Option-1. It always calls Centered Text style, even if I have deleted that style and the only opened document doesn’t contain that style at all.
Any suggestion?

Would it be possible to send a copy of the project so we can take a look at how it is set up internally? If so, please send a copy to our support address, and make sure to note the forum thread URL so that whoever gets it can put you in touch with me.

I’ve never seen anything like this, and I definitely fit the profile for the possibility of seeing it. I deleted the “Centered Text” style from my defaults over a year ago, and have my own custom heading set to ⌥⌘1—never seen it do anything other than precisely what it should.

Thank you very much for your answer. I’ll send the project to the referred e-mail.

Thank you for the sample project. It looks like everything is set up correctly within it, and for myself when I use ⌥⌘1 on a test line of text, it adopts the “Des” style, as I believe you intend? That is the style configured to use that shortcut at any rate.

I would maybe try reinstalling the software from a fresh download. And also go through System Preferences: Keyboard, through all of the sections, and make sure this shortcut isn’t used by anything else, or that you don’t have a custom setting for Scrivener.

The part where you described “Centered Text” being assigned (and I assume you mean that fully, as in the Format Bar declares that text when the cursor is in the paragraph) even though it doesn’t exist in the project is so peculiar and theoretically impossible, that we might as well make sure the installation isn’t damaged.

Thank you very much for your answer (from a city very close to my place).
Yes, I want to assign Cmd-Option-1 to DES style.
That shortcut is not present in the Keyboard section of my System preferences. Checked and re-checked.
You’re right: maybe a fresh install could be the solution, but I am bit reluctant because of my heavily customized Scrivener setup…
Best wishes.

A fter a fresh download and a clean installation, the problem is solved in the administrative account but not in the standard user account (the one I use every day). Any suggestion?

It’s obvious but it’s necessary to avoid any misunderstanding: if I use the mouse and I select the paragraph via the Styles panel, no problem at all.

I have erased the Scrivener Application Support folder and the .plist file in the Preferences Folder (Standard user account) , but, unfortunately, the same behaviour persists.

Hopefully you kept a copy of the Application Support folder so you can replace it. The only possible thing in there that might be of impact is the default default_styles.xml file, which will appear if you modify the default stylesheet for new projects.

I’m still a bit unclear on what you mean by the “Centered Text” style being applied when there is no such style in the project.

  • Is that what it says in the Format Bar?
  • If you drag the document with the marked text to a project binder that has a “Centered Text” style, is it marked as such there?
  • If you change the colour of the text and then redefine the style that is indicated in the user interface, what changes, other text that looks like “Centered Text”, or text that looks like “Des”?

Another way of putting that last one is: does ⌥⌘1 assign text to the right style but with the wrong appearance, so that all of the test text changes to the new colour whether it looks like “Des” or “Centered Text”, or are there actually two different styles, one that is picked with the mouse and one that is set with the shortcut?

Maybe, my message was not clear enough. Excuse me.
The “Centered Text” style is not present at all in my document (it was erased), but Cmd-Option-1 (currently assigned to DES style) has the effect of centering the text in the paragraph, instead of applying the DES paragraph format. The DES style, if applied using the mouse, acts exactly as expected.

Hmm, I didn’t notice this condition in the sample you sent, but maybe you’ve got scriptwriting mode turned on? If the footer bar along the bottom of the editor lacks word/character statistics and has some hint text on Return/Tab instead, try hitting ⌘8 to toggle scripting mode off, and try setting the style again.

When in scriptwriting mode, all of the style shortcuts are rewired to scriptwriting elements (Character, Dialogue, etc.), since styles have little purpose in that form of writing.

Scriptwriting mode is off, without any doubt.

I have a solution! At last! I can use the sortcut if I press the 1 key in the numeric keyboard!!! Obviosuly, this turnaround doesn’t work in the MacBook (it doesn’t include numeric keyboard).