Comic Script Template

There’s this lovely Template for making a Comic Script, and I started using it today.
But here’s my curiosity: the comic page template you are given to start with already has on it:
PAGE <$N>
PANEL <$SN>
But I can’t find out how to make a second panel header. None of the templated things like Scene Heading, Action, Character, etc., none of those match the formatting of the PANEL <$SN>, but it says in the About This Template: “Panel Number is used to denote a single panel of comic art on the page. Press TAB after typing to insert the <$sn> string, which will auto-number your panels within each page during the Compile process. Press ENTER to automatically put the text into Panel Description mode.” But it doesn’t say how to get there in the first place.

I don’t know if this is exactly a bug, but it’s bothering me … I suppose I could go back to CeltX (which is lovely, don’t get me wrong … but I love Scrivener so much … )

Mmm, the problem is that the template is set up for the Mac version of Scrivener, and apparently not everything translated to the Windows version. Using the template on the Mac, the scriptwriting elements have been changed to things like “page number” and “panel number”, etc. which don’t appear in the Windows version. Ergo hitting tab isn’t working like it ought.

It does look like you can set elements and such in scriptwriting, so it’s probably possible to adjust it…I tried to save the settings from the Mac version and load them in the Windows, but that didn’t quite do it, so I’d have to play with it more to figure out how to jiggle it into working. Also I haven’t checked any of the scriptwriting bugs/tech issues to know what’s actually just not working yet, so this may just be something you need to wait on. But someone who’s been doing more with scriptwriting in Windows (or more in Windows in genera!) might have a better take on that.

Thank you for the reply! That makes sense. I’ll have to play around with it some …
Do you know, does the <$N>/<$SN> thing work in Scrivener for Windows? I’ve seen mention of it in templates, but I’ve never seen it actually in action …

They should be lowercase, but yes, they work. (I don’t know why they’re capital, actually; it should be lowercase for the Mac, too, although it seems to still compile properly in the Mac version whereas the case makes a difference in Windows.)

Tested it briefly in the Windows version and it worked as expected.

Thanks again, I really appreciate it.
Comic Script: here I come!

Problems with customizing my screenwriting options:
I went into Format > Scriptwriting > Script Settings, to make myself a format that would work. I added Page Number and Panel Number to the format options, and set about making it so that:

  1. When in Page Number, tabbing after typing would insert <$n> (and the reason it was capitalized was probably because whatever format created that heading was told to be all caps, so I left that unmarked), and then hitting Return would take you to the Panel Number setting.
  2. In Panel Number, again, tabbing after typing would insert <$sn>, and hitting Return after that would take you to Action.
  3. I had to close the Script Settings box to make the new formats show up in the drop-down menu.
  4. I set about systematically setting up the other formats so that they would go to Panel Number when I was done with a panel.
    When I was done with all that, I went back to my script to try it out. First thing I noticed was that Page and Panel Numbers did not show up in the little “drop-down” menu at the bottom of the screen, the one that lists all the others, including Scene Heading, which I had deleted the first time I tried this. So I thought, okay, maybe I have to close Scrivener and restart it.
    So I did that, and found that all my hard work had disappeared, and that the settings hadn’t been saved.
    So I redid everything, and then tried to go from Dialogue to Action by hitting Enter, and then from Action to Panel Number by tabbing on an empty line. That was how I’d set it up. There were some problems with that, and I’ll try to remember them best I can.
    Hitting Enter from Dialogue wanted to go to Parenthetical, even though that was only suppose to happen with a tab (either on an empty line, or after typing). I fixed that by telling the Script Settings to go to Action when tabbing–but I don’t remember which one, and when I tried hitting Enter after a dialogue just now (on a freshly opened Scrivener), it worked just fine.
    Either way, I went from a line of dialogue to an empty action line, at which point I hit the Tab button, and then tried to type the word Panel so I could tab after that and see if it would insert <$sn> for me.
    Instead, I got the “Scrivener.exe has stopped working” dialog box, and I had to close Scrivener.

I’ve had some other trouble with the scriptwriting format and Scrivener freezing up, but this was bad.
Also, less buggy, but things that bothered me (aside from my settings not being saved, which I assume was a bug):

  1. When making Page Number and Panel Number settings, I couldn’t move them to the top of the list, which I wanted to, because they’re the first things that happen on a page of script, and it just would have looked neater.
  2. The fact that they didn’t show up in the drop-down list of options bothered me, too. Don’t know if that’s a bug or an oversight or what. (Actually, that’s a rather major problem, considering that I can’t start a page with Page Number unless I can select it from the drop-down list at the bottom of the page.)

Thanks!

Tried it again to see if it was reproducible.
Add Page Number and Panel Number to Script Settings. Make them both Courier New, Bold, Underline, 14- and 12-point font respectively.
Close Script Settings and reopen it. Go to Tab/Return panel, and make Page Number go to Panel Number on Return and Tab on Empty Line, make Tab After Typing insert <$n>. Make Panel Number go to Action on Return and Tab on Empty Line, make Tab After Typing insert <$sn>. Go to Action and make Return go to Character, Tab on Empty go to Panel Number, and Tab After Typing go to Action. Then close it, and from a line of dialogue, hit Enter. It will go to Action. On an empty Action line, hit Tab.
Scrivener.exe has stopped working …