Comment and Footnote function not working

Just installed, and did update to 1.5.3
Going through tutorial, and the comment and footnote function does not show up at all in the Inspector panel.
In the tutorial:
“Note how the inspector automatically switches to the Comments & Footnotes pane, and the comment associated with the text gets highlighted.”
This did not happen. No Comments and Footnotes bar shows up.

“or use the Format > Comment menu command.”
There is not Comment option when I open the Format button on the menu.

Everything else seems to work fine.

I think you probably just need to click on the editor window first, at the point at which you wish to attach the footnote or comment. You should see that flashing vertical line in the editor, then your options should become available.

Still not working the way it is advertised in the tutorial, but I did notice that the comment and footnote parts of the “Format” tab have now appeared, but they are dimmed. It does not matter if I am in the editor or Inspector panel. If I use the keyboard shortcuts, Shift F4 and Shift F5, then I can create a comment or footnote from selected text. Also, the buttons at the top of the Inspector panel remain dimmed all of the time.

I can make mine NOT work too if I’m in scrivenings mode on a folder, instead of just document view of a text document. Otherwise, it should work unless there is some setting I’m not aware of. I’m kind of a newbie so maybe there’s something else.