Comment Highlights and Links

I’m trying to toggle the Comments Highlights and Links on/off for readability. The Scrivener 3.0x manual says this can be done:

Text Editing ▸ Show|Hide Markup Toggles the display of textual markings, to produce a cleaner copy suitable for proofreading. The markings that will be hidden by default are comment highlights, links, highlight boxes around styled text and preserve formatting boxes. You can adjust what markings are hidden in the Appearance: Textual Marks (subsection B.5.16) pane.

I’ve tried this several times without success. Is anybody else having a problem wit this?

Thanks!

Are you sure that the highlight in question is for a comment, and not an annotation or footnote?

Katherine

Yes. They are from text and comments loaded from Word.

Yes. They are from text and comments loaded from Word.

This should be working fine (I just double-checked). Could you please post a screenshot showing what you are seeing with this option turned on?

Ideally, all the text below would be black on white.

I have 400+ pages of this, so you can imagine the desire to toggle the comment highlighting on and off.

Thanks for looking into this!

And when it’s like this and you go to View > Text Editing, does it say “Show Markup” or “Hide Markup”? When I turn off markup it works fine, so I can’t reproduce the problem at the moment, I’m afraid.

View > Text Editing > Show Markup <-- what displays

Very strange! Is this happening in all projects or just one? What happens if you quit and restart Scrivener and try again?

All the best,
Keith

Unfortunately, yes. It’s happening across projects. Shut down computer completely, brought it back up. Issue the same, across projects.

Scrivener (3.02 – 3.00 also, though) mac os 10.13.4, iMac Retina 27"

One other thing to check:

  1. Open Scrivener’s Preferences (Scrivener > Preferences).

  2. Go to “Appearance”.

  3. Select “Textual Marks” in the list on the left.

  4. Check that “Comment highlights” and “Links” are ticked under “‘Hide Markup’ hides:”.

All the best,
Keith

That did it. Awesome. What I’ll call the “double negative” was throwing me.

Now for a menu feature request. A toggle: Comment Highlights ON/OFF (A menu customization option)

Thank you. This really helps. Awesome software.

I’m bumping this in case anybody else has this issue. I’ve upgraded to Scrivener 3.0 for Windows (released today! yay!), and can’t hide comments. I 've followed the steps above and haven’t managed to hide comments, but perhaps others will be more successful.