Comment removal affects formatting - very bad bug

I have the following piece of text:


I’ve marked it as a comment:

Then I removed the comment by clicking on the x in the corner…

Which, as a result, quietly moved the italics to a different line.

Which is not optimal to say the least.
I’m now in the middle of the last edit of my book, 226k words, 184 documents… It’s not the right moment to start going back over the entire thing AGAIN to make sure adding and removal of comments did not eff up my formatting everywhere. But I have to. Thank goodness I don’t have a deadline, but I have to say, this isn’t helping.

Yes, that is a bad bug, but, as a work-around, can you not simply set comments not to compile, rather than going through and deleting them?

Just a thought.

Mark

Probably yes, but I use them as a ticketing system, in a way - a comment means there is a point to be resolved. And now that I know it happens, I will be paying attention…
Also, even if I stopped deleting them RIGHT NOW, who knows how much text has been messed up until now - I’m around 2/3 in my current round of revisions… I can’t just go and recover a version from 10+ days ago, because it doesn’t contain the corrections.

I’ll probably have to compile both to Word and do difference check on formatting level.

Ouch! Not good. For the future, until the bug’s squashed should you still have the same problem on other projects, my solution would be, when I had dealt with the ticket, I’d use strikethrough on the text of the comment or simply replace it with “resolved” and then not compile the comments.

:slight_smile:

Mark

Probably so, yeah. Right now I’ll be not-so-happily compiling an early-July version in portions of 1/6 of the text, hoping for not too much formatting to be redone.

Additional little weirdness.
I had a comment over a bigger piece of text, then I pasted a line in that text. The comment split (the newly pasted text was not coloured). I removed the comment from the list by (x), and the top half of the text got cleared.
The bottom half stayed coloured, so I clicked on it to check what would happen.


I must say I haven’t seen this kind of interface element in Scrivener before :slight_smile:

It’s a Feature. Not a bug. :slight_smile:

I work in IT, too :stuck_out_tongue_winking_eye:
If it’s a feature, how do I make it show up normally?

"Pop-up Notes

A different way to view Notes is a pop-up over the highlighted text. To get this working, deselect the checkbox [Open Comment in Inspector if Possible] in [File > Settings > Editing > Options]. When the Foot and endnotes pane in the Inspector is open, the Notes and Comments will still show up there, but when another tab is open or the Inspector is closed, a pop-up will appear containing the Notes content, a way to navigate to the Next or Previous Note, and a button to Delete that Note" - Mastering Scrivener - Advanced Scrivener 3 for Experienced Writers by Antoni Dol.

Ooh. Lovely. Thank you :slight_smile:
However, this happened to me when the Inspector was most certainly opened.

THAT would be a bug. :wink:

1 Like

Sorry for the delay in following up on this one. I’ve tracked all of the issues down to what appears to be a central issue with how comments are handled on top of formatted text, and filed a report.

Thanks for the details, all!

1 Like

Is there any kind of timeline for this correction?
Recently I had a whole block of text turn to Italic when I added the comment, so it’s not only removal that’s messing up the formats. A few more of these and comments will become more of a threat to my writing than a benefit…

Unfortunately, L&L no longer provides timelines or estimates for any bugfix or new feature, or even update. No matter how they qualify them as an estimate, a small but vocal group of people insisted on reading them as promises and were consistently abusive when even tentative dates were adjusted/slid.

2 Likes

Hello,

Every time I put a comment on a text containing italics and normal font, it makes all the commented text either all italics or all normal.
I tested it a bit and it seems that it takes the formatting of the last word and apply it to every word.
For example, if I put a comment on [This and that], it will render like [This and that] and if it’s [This and that], it will be all [This and that].
It doesn’t change anything unless you actually type your comment in.
And sometimes, when you do a Ctrl+Z / Ctrl+Shift+Z, it does get back with the comment and the expected mixed formatting, so that’s odd.

I tested it on a new document also, just in case.
Is it a known bug ?

Just to ask a further wrinkle, when you highlight text to add the comment, do you go from right to left or left to right, and does that make any difference?

I’m a Mac user and not at my computer at the moment, so I’ll leave it to others to respond further.

:slight_smile:

Mark

Interesting idea, but I just tried both, it doesn’t change anything.