Comments are published

I have “Remove inspector comments” checked, but the comments are still published. Inline annotations aren’t. version

What format are you compiling to? I’ve tried compiling to RTF with “Remove inspector comments” checked and “Remove inline annotations” deselected and it works as expected. What happens if you reset the compile settings to the “Original” preset and compile? (Doing so will of course wipe any other custom settings you had in compile, so you may want to choose Save Preset first; then you’ll be able to return to your current settings after the test.)