Comments excluded from compile, but asterisks remain

Hi there,

The subject line says it all: When excluding comments from compile, some asterisks remain in the main body of the text. What can I do about that?



Could you point out which features you are making use of, by name? I’m unclear on what you mean here, as Comments have nothing to do with asterisks. If you typed an asterisk into the editor and then attached a comment to it, then that is your choice, but the comment feature itself has no idea that you wanted it removed. Comments are meant to be used as a highlight on otherwise printable text.

If instead you want comments in the text that are removed, then inline annotations may be a better choice.

One thing I can think of is that you use the footnote marker setting in Project Settings: Formatting. But as you can see, that only pertains to footnotes. Maybe at some point you converted some footnotes to comments, and so they stopped removing the asterisk? It’s up to you to reattach a comment and remove any marker text, if that’s the case.

Many thanks for your reply!

Indeed, that’s what must have happened (years ago when I was still figuring this stuff out): I must have “typed in” the asterisk and then attached the comment.

Sorry for wasting your time.