Comments functionality broken in Windoze

Hello,

This is my first post here.

I’ve been going through the tutorial, and it appears that the comments utility is broken. In step 5H (Comments & Footnotes), it suggests highlighting text to be included in the comment, then clicking on the little box with the N, then doing either of the following 3 actions:

  • Click on the + sign above the comments pane on the right,
  • Click on Format>Comment on the menu bar,
  • Press

None of these methods works.

I had noted a few other tasks that had multiple ways of performing them, and some of the methods described did not work, but others did. However, in the case of comments, at least in this installation of Scrivener, this is completely broken. I’m running Windows 7 64-bit on a very new computer with quad-core processor and half a terabyte of free disk space. Please advise, and thanks.

Regards,

Alan

Hello Allan,
Not sure how you’re going about it, but until the real help arrives i can assure you that all three methods works just fine and I am using scabby old Vista on a nail of a PC. Highlight the text with mouse selection and any of the three methods you quote work without a hitch.

Hmmm, I confirm that comments functionality is not working for me either.
Scrivener 1.5.3.0 on Windows 8 32 bit, in desktop mode.

64 bit Windows 7 here. I’ve just tested again to confirm and notes of both types are working for me. If it were just the keyboard shortcut, I would suggest resetting them in the Tools/Options… pane, under Keyboard. If you click the arrow beside “Import” and choose Scrivener then click Okay, that should fix upgrading issues—but you indicate they don’t work anywhere. Have you made sure to update to the latest build? You might need to download the installer from the web page and try again. You can just re-install over the existing copy; no need to uinstall. There were a few issues with notes that were fixed quickly, and maybe you ended up with one of these interim releases.

I should also note that I’m currently testing with an internal 1.5.4 build, so I might be missing something specific to an older versions.

Hi,

I do also experience problems with the inspector comments functionality: Either they spontaneously disappear in the inspector, appear later on; or even the Scrivener process gets frozen (see screenshot) when I try to edit or remove an inspector comment… Then, Scrivener process needs to be killed…

Win7 64bit
Scrivener 1.5.3.0

I notice you’re located in Germany, have you determined if the problems only arise when using non-ASCII characters in notes? That might be the missing ingredient, as my testing is all done in with the characters English uses.

I did not notice that it would depend on non-ASCII characters… but haven’t yet test this explicitly.

But if you split a word in the editor which the inspector comment was originally assigned to, then
Scrivener freezes if you try to remove the comment via the inspector buttons.
Please see the second inspector comment in the attached project: the word “english” was re-edited into:

eng

HALLO

lish

scrivener_comments_tests 2013_03_14_11_50_01.zip (9.13 KB)

Hey all,

I have a problems with comments and footnotes as well:
I can create them and write something in the comment/footnote field, but I can´t edited them once I went back to the main text. If I wrote something wrong or forgot something, I have to delete the original and create a complete new comment/footnote.

I asked a friend who is using the Mac version for some years and I know that she can edit footnotes and comments.

I´m on Windows 7 32 bit. FWIW, I´m in Germany as well and using the German dictionary.

Sarah

I am noticing the same problem as Sciley: When I first create a comment or footnote, I can edit the text – but after that I can’t find any way to edit the text of that comment or footnote.

Seems to me the problem is related to the way that clicking on a comment or footnote will scroll the main window to and select the text being commented on. There’s a right-click menu option on the comments to “Select All” which selects the text of the comment itself, but if I start typing with that selected nothing changes.

I am on a clean install of version 1.5.6.0 on Windows 7 x64 with 'merican English language.

I had the same frustration with editing comment text for a while too. What I found that works (on my machine anyway) is to click the comment you want to edit, then double click it again. The first click brings the focus onto that comment then the double click let’s you edit.

Sure enough, that works for me too.

(Could have sworn I’d tried that before, but since it isn’t obvious that the cursor gets placed at the end of the comment until you type something that moves the cursor, I probably just didn’t notice.)

Thanks, Sanguinius!

Thank you, Sanguinius. That works for me, too!

To pop in here rather late (sorry!), I do have this on the list for improvement, as there are definitely some quirks with editing inspector comments and footnotes and how text appears selected, etc. You should always be able to edit them, and it sounds like Sanguinius has resolved that for everyone–click to select, double-click to edit–but the text selection at that point isn’t always rendering properly, so it can be difficult sometimes to see. It shouldn’t prevent you actually working, but anyhow I wanted to assure you all that we’re aware of the problems and will be looking at ways to improve the comment/footnote handling.

Thanks for the info, MM