Compilation deletes all my linefeed and carriage return ! SOS

I have a major difficulty in compiling my documents.
The software deletes all my linefeed and carriage return, this gives an unreadable text since without breathing, totally pasted… none of the formats present in scrivener gives me a correct document respecting my line breaks and carriage return.

There isn’t a dedicated feature that would do that, but you could certainly tell the compiler to strip out line endings with the Replacments tool. Check that tab in the main compile overview screen, checking for any lines that look empty in particular. You can simply uncheck them rather than deleting them, to test. If you have created a custom format, you’ll also want to edit it and check its Replacements table as well.

hello and thank you for your feedback,
I found my problem with my markdown signs that are problematic. When I uncheck them in the compilation editor, I have an output that respects my line breaks again.
I’ll look into it!

Oh, yeah Markdown is another thing that could do that. If you’re using a Markdown engine to convert your text then you’ll need to have double-spaced paragraphs, because it considers one line next to another as being in the same paragraph. It is useful for email and other hard-wrapped text sources, but also single-spaced paragraphs in plain-text look awful, so there is little point in working toward that look.

I use Markdown with Scrivener. Personally I just double-space everything, I think it looks better anyway, and it’s as habitual to me as pressing the spacebar after every word. But if you really want things to look like a word processor in Scrivener, there are ways to spread paragraphs apart. Replacements in fact is one of them. :slight_smile: But converting paragraph spacing to literal whitespace is the best option. You’ll find it in the Transformations compile format pane.