Compile and Project Mix-up

DarkRevolution Layout.JPGA few weeks ago, I had a problem with a project I was setting up.

[url]https://forum.literatureandlatte.com/t/disappearing-work-ghak/30232/1]

I got it set up again – created a new project, copied some of the stuff that hadn’t vanished on me over to the new project, and then did the set-up again.

All seemed to be working well.

Then I went to compile it.

Two of the files which are in my Research folder are turning up in the Compile and Research is unchecked for inclusion in the Compile. Those are, so dar, the only files from Research which have turned up in the Compile.

I attach the sidebar of the project. The file labeled “Aliza and Gemini” turns up attached to “Simon and Kira,” followed by “Gemini’s Thoughts” with a page break. Yet neither file is attached to the “Simon and Kira” one when I look at it in Scrivener.

It’s really screwy.

I’m guessing that in your Contents section of the expanded compile window, you have it compiling a collection instead of the contents of the Draft folder. Look there for a drop-down control that allows you to select Draft.

No collections in the Project!

Have you tried a project search for the files or text within them in case there are accidental duplicates or a copy of the text in the wrong location (e.g. appended to the end of the “Simon & Kira” document or as part of the “Mountain Home” folder)? What does the compile contents list look like?

First thing I did was check the file “Simon & Kira” to see if those pieces had been inadvertently appended to it. No dice.

Those two pieces, plus a small chunk of “Aliza and the Major” fall between “Simon and Kira” and “Mountain Home” – and that’s NOT where they’re supposed to go, nor are they there when I check MH or S&K.

This is what the Compile dialog looks like at that point:

You are using folders as containers for text files in the main, it seems.

However, in Mountain Home, you have got text written in the MH folder itself (I am assuming Windows icons are similar to Mac ones.)

You say that the extraneous text appears between Simon and Kira and Mountain Home.

Do you actually mean between Simon and Kira and First Meeting?

If that is the case, the extraneous text is probably in the Mountain Home folder.

If you turn off scrivenings view and then look at Mountain Home in isolation, do you see the extraneous text?

Apologies if this is too obvious or daft. Just trying to help. :blush:

Yes, I am using the folders as containers for text documents.

However, despite the different icon on Mountain Home, there’s nothing in it except the text documents below it.

It lists 17 files – and there are 17 files below it, none of which contain the text which is turning up in the wrong place.

DarkRevolution Layout03.JPG

On a Mac, that icon means that the folder itself has some text in it.

In the list below, the folders for Stand & Deliver and Gregori PP both have text written in them.

The other two folders, Stone the Crone and Header and Footer, don’t have text written in them.

[attachment=0]icons.png[/attachment]

I just looked at the Scrivener for Windows manual, and that says that a folder icon with a superimposed printed page means that the folder itself contains text.

As the problem seems to be at that point, perhaps it would be worth creating a new Mountain Home folder, dragging the 17 files into that and then moving the old MH folder to the trash or somewhere else. Hopefully, this will remove the extraneous text, as Scrivener seems to think that the current MH folder does contain text.

What I cannot figure out is why I cannot see the text in that folder when I open it. It simply does not appear, except when compiling.

However, it looks as if the new Mountain Home folder may have solved the problem.

Now to go look up my directions for creating a ToC… I know I have some somewhere.

After you’ve selected the Mountain Home folder in the binder, deselect the current (orange-highlighted) group view mode in the main toolbar to show just the folder’s text. You can also enable “Include enclosing group in combined Scrivenings” in the Navigation pane of Tools > Options to have the folder text included at the top when the folder is displayed in Scrivenings mode.

Creating a Table of Contents is described in section 22 of the user manual, for reference.

Okay – and yes, the text in the old “Mountain Home” Folder is the stuff that is showing up out of place. What I do not understand is how it got there, since I certainly did not put it there deliberately. (I admit, I am not ruling out the possibility that I screwed something up.) It may have been a result of the squirrel-up I had with this project before.

I did look up the ToC in the manual. My problem is that I apparently don’t think the same way the writers of the manual do, because most of the time, the directions do not make sense to me. This is not, I hasten to add, the fault of the manual writers and organizers, but a peculiarity in the way I think.

I am going back through this thread
[url]https://forum.literatureandlatte.com/t/using-the-compiler/28696/1]

where a number of things were worked out, but I still have a ways to go, as I have not yet gotten the ultimate format for the way I do my manuscripts.

When I have re-read that thread, I may have the solution to the fact that Folder names turn up in the Compile as separate “Chapter.” It seems to me that the last time I was working on Compile, I also had that problem, and it was worked through.

I just wish I understood all the “levels” better.

As I have said before, it’s clear that Compile is an incredibly powerful tool, but a person could write a thousand page book on Compile, and, I think, not cover everything it can do.

Levels are equivalent to the binder indentation. Draft, Research, and Trash are at level 0, so you can think of that as your base; a document directly in the Draft will be at Level 1, and its child will be Level 2, and so on. Using your binder image, you’d have this:

Draft (Level 0)

  • Front Matter (Level 1)
    • Dark Revolution B (Level 2)
  • Kira & Matt (Level 1)
    • AKA02_S (Level 2)
    • AKA_S (Level 2)
    • Simon & Kira (Level 2)

In the compile, the formatting row applies to all included items of that type (folder, document group, or document) at the given level. When you see a + at the end, e.g. Level 1+, it means that the formatting will apply to all higher levels of that type also. So Folder Level 1+ would apply also to folders at Level 2, 3, 4, etc.

To give Level 1 folders distinct formatting, select the row and click the button in the upper right to add a new formatting row for that type. The original level will now be simply “Level 1” and the new row will be “Level 2+”, formatting folders at level 2 and higher.